aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-02 17:25:00 +0800
committermaho <maho@FreeBSD.org>2007-01-02 17:25:00 +0800
commit5058c4b15ac55e519675b672b1335c02f63a5853 (patch)
treed4ebe61e05b9581ffb694a1fd763d59a847b966b /science
parentb7e20ba55db0ec1b59a55e8207c47b9c2a0a0126 (diff)
downloadfreebsd-ports-graphics-5058c4b15ac55e519675b672b1335c02f63a5853.tar.gz
freebsd-ports-graphics-5058c4b15ac55e519675b672b1335c02f63a5853.tar.zst
freebsd-ports-graphics-5058c4b15ac55e519675b672b1335c02f63a5853.zip
* From PORTREVERSION to PORTREVISION.
* Add symlink to version numbered shared libs. e.g. lib*.so to lib*.so.1.
Diffstat (limited to 'science')
-rw-r--r--science/libint/Makefile7
-rw-r--r--science/libint/pkg-plist3
2 files changed, 9 insertions, 1 deletions
diff --git a/science/libint/Makefile b/science/libint/Makefile
index 6cbe9fb4a2a..8bcaa3749fe 100644
--- a/science/libint/Makefile
+++ b/science/libint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libint
PORTVERSION= 1.1.2
-PORTREVERSION= 1
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.ccmst.gatech.edu/evaleev/libint/src/
@@ -24,4 +24,9 @@ ALL_TARGET= # empty
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-shared
+post-install:
+ @${LN} -sf ${PREFIX}/lib/libderiv-stable.so.1 ${PREFIX}/lib/libderiv.so.1
+ @${LN} -sf ${PREFIX}/lib/libint-stable.so.1 ${PREFIX}/lib/libint.so.1
+ @${LN} -sf ${PREFIX}/lib/libr12-stable.so.1 ${PREFIX}/lib/libr12.so.1
+
.include <bsd.port.post.mk>
diff --git a/science/libint/pkg-plist b/science/libint/pkg-plist
index ba79d70180c..206bc133f9b 100644
--- a/science/libint/pkg-plist
+++ b/science/libint/pkg-plist
@@ -11,13 +11,16 @@ lib/libderiv-stable.so.1
lib/libderiv.a
lib/libderiv.la
lib/libderiv.so
+lib/libderiv.so.1
lib/libint-stable.so
lib/libint-stable.so.1
lib/libint.a
lib/libint.la
lib/libint.so
+lib/libint.so.1
lib/libr12-stable.so
lib/libr12-stable.so.1
lib/libr12.a
lib/libr12.la
lib/libr12.so
+lib/libr12.so.1