aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-10 11:39:15 +0800
committermaho <maho@FreeBSD.org>2007-01-10 11:39:15 +0800
commit5f9a34989e7b98af1098b0a9fbcac093f9e7e651 (patch)
tree33625bff035d8d7a253a6d04158faf76763fc05c /science
parent9ea1ea3a573df287d139bcb304ebd0154cde9947 (diff)
downloadfreebsd-ports-graphics-5f9a34989e7b98af1098b0a9fbcac093f9e7e651.tar.gz
freebsd-ports-graphics-5f9a34989e7b98af1098b0a9fbcac093f9e7e651.tar.zst
freebsd-ports-graphics-5f9a34989e7b98af1098b0a9fbcac093f9e7e651.zip
* Migrate to gfortran42.
Diffstat (limited to 'science')
-rw-r--r--science/elmer-hutiter/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/science/elmer-hutiter/Makefile b/science/elmer-hutiter/Makefile
index b06eed3240b..bc2a119f495 100644
--- a/science/elmer-hutiter/Makefile
+++ b/science/elmer-hutiter/Makefile
@@ -14,22 +14,32 @@ PKGNAMEPREFIX= elmer-
MAINTAINER= ports@FreeBSD.org
COMMENT= HUTIter library for use in the ELMER FEM package
-BUILD_DEPENDS= ${LOCALBASE}/lib/libblas.a:${PORTSDIR}/math/elmer-mathlibs \
- ${LOCALBASE}/lib/liblapack.a:${PORTSDIR}/math/elmer-mathlibs \
- ${LOCALBASE}/lib/libarpack.a:${PORTSDIR}/math/elmer-mathlibs
+WANT_FORTRAN= yes
+USE_GCC= 4.2+
-USE_GCC= 4.1+
+.include <bsd.port.pre.mk>
+
+LIB_DEPENDS= arpack.1:${PORTSDIR}/math/arpack
+.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.endif
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+BLAS= -lf77blas -latlas
+LAPACK= -lalapack
+.else
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+BLAS= -lblas
+LAPACK= -llapack
+.endif
-F77= ${FC}
-WITH_FORTRAN= yes
-CONFIGURE_ENV+= FC=${FC} F77=${FC}
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= FC=${FC} F77=${FC}
ALL_TARGET=
PLIST_FILES= include/huti_defs.h include/huti_fdefs.h lib/libhuti.a
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CFLAGS+= -fPIC
FFLAGS+= -fPIC