aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2009-11-28 18:44:56 +0800
committerthierry <thierry@FreeBSD.org>2009-11-28 18:44:56 +0800
commit821dbba052a0ebd1ff69db896a7e5af7c9a21fd9 (patch)
tree83ed04ecf451d9c7a671e32f6ad037860245534a /science
parent6156d85b8e504b4e5ea95a6e25e7d34c0e31fde6 (diff)
downloadfreebsd-ports-graphics-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.tar.gz
freebsd-ports-graphics-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.tar.zst
freebsd-ports-graphics-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.zip
- Chase relocation of net/mpich2
- Bump PORTREVISION if needed - Fix some portlint errors.
Diffstat (limited to 'science')
-rw-r--r--science/fvm/Makefile7
-rw-r--r--science/gromacs/Makefile2
-rw-r--r--science/mbdyn/Makefile6
-rw-r--r--science/mpqc/Makefile8
-rw-r--r--science/ncs/Makefile4
-rw-r--r--science/pnetcdf/Makefile7
6 files changed, 18 insertions, 16 deletions
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
index 246a9b7d016..9c539f5a111 100644
--- a/science/fvm/Makefile
+++ b/science/fvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fvm
PORTVERSION= 0.12.0
+PORTREVISION= 1
CATEGORIES= science parallel
MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -39,9 +40,9 @@ BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}/mpi/openmpi
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
-CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}
.endif
.if defined(WITH_DEBUG)
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 8c11148bb71..b316e576b06 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -86,7 +86,7 @@ PLIST_SUB+= SUFFIX_D=_d SUFFIX_DOUBLE=_double
.if defined(WITH_MPICH) || defined(WITH_OMPI)
CONFIGURE_ARGS+= --enable-mpi
.if defined(WITH_MPICH)
-CONFIGURE_ENV+= MPICC=${PREFIX}/mpich2/bin/mpicc
+CONFIGURE_ENV+= MPICC=${PREFIX}/bin/mpicc
BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
RUN_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
.elif defined(WITH_OMPI)
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 250b3e4d039..feee992e3e3 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -45,15 +45,15 @@ LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
CONFIGURE_ARGS+= --with-blas=goto
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-CONFIGURE_ARGS+= --with-blas=atlas
+CONFIGURE_ARGS+= --with-blas=atlas
.endif
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
.if defined(WITH_MPI)
LIB_DEPENDS+= mpich:${PORTSDIR}/net/mpich2
CONFIGURE_ARGS+= --with-mpi=pmpi
-CPPFLAGS+= -I${LOCALBASE}/mpich/include -I${LOCALBASE}/mpich/include/mpi2c++
-LDFLAGS+= -L${LOCALBASE}/mpich/lib
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/mpi2c++
+LDFLAGS+= -L${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --with-mpi=no
.endif
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 5eb74c7c296..0fbc4b8f32e 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= science parallel
MASTER_SITES= SF
@@ -22,7 +22,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if defined(WITH_ICC)
-BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
+BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
@@ -72,11 +72,11 @@ CONFIGURE_ARGS+=--with-cc=${CC} \
CONFIGURE_ARGS+=--with-libs="-lsvml"
.endif
.if defined(WITH_MPICH)
-CONFIGURE_ARGS+=--with-libdirs="-L${LOCALBASE}/lib -L${LOCALBASE}/mpich2/lib"\
+CONFIGURE_ARGS+=--with-libdirs="-L${LOCALBASE}/lib -L${LOCALBASE}/lib"\
--enable-always-use-mpi
.endif
.if defined(WITH_MPICH)
-CONFIGURE_ARGS+=--with-include="-I${LOCALBASE}/mpich2/include -I${WRKDIR} -I${LOCALBASE}/include"
+CONFIGURE_ARGS+=--with-include="-I${LOCALBASE}/include -I${WRKDIR} -I${LOCALBASE}/include"
.else
CONFIGURE_ARGS+=--with-include="-I${WRKDIR} -I${LOCALBASE}/include"
.endif
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index ea529a358a3..8844edfe14a 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ncs
PORTVERSION= 1.3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science parallel
MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -64,7 +64,7 @@ BUILD_DEPENDS+= ${MPI_HOME}/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${MPI_HOME}/bin/mpirun:${PORTSDIR}/net/openmpi
MPI_LIBS= -lmpi -lorte -lopal
.else
-MPI_HOME= ${LOCALBASE}/mpich2
+MPI_HOME= ${LOCALBASE}
BUILD_DEPENDS+= ${MPI_HOME}/bin/mpicc:${PORTSDIR}/net/mpich2
RUN_DEPENDS+= ${MPI_HOME}/bin/mpirun:${PORTSDIR}/net/mpich2
MPI_LIBS= -lmpich
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index 188ec2533c3..1d035c6c648 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pnetcdf
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= science parallel
MASTER_SITES= http://ftp.mcs.anl.gov/pub/parallel-netcdf/
DISTNAME= parallel-netcdf-${PORTVERSION}
@@ -40,9 +41,9 @@ BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}/mpi/openmpi
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/lib/libmpich.so:${PORTSDIR}/net/mpich2
-CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/lib/libmpich.so:${PORTSDIR}/net/mpich2
+CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}
.endif
post-patch: