aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-05 14:00:34 +0800
committerkris <kris@FreeBSD.org>2004-02-05 14:00:34 +0800
commit9e92b7c8fa0f9f95ad386584211acba5610e94e4 (patch)
tree53018d32b4c0f3ff36455d834f17fb17c5475958 /science
parent401e9a5d38f0c8b7b04e96cda97f903dcbbc0c14 (diff)
downloadfreebsd-ports-graphics-9e92b7c8fa0f9f95ad386584211acba5610e94e4.tar.gz
freebsd-ports-graphics-9e92b7c8fa0f9f95ad386584211acba5610e94e4.tar.zst
freebsd-ports-graphics-9e92b7c8fa0f9f95ad386584211acba5610e94e4.zip
BROKEN: Does not compile on 5.x
Diffstat (limited to 'science')
-rw-r--r--science/netcdf/Makefile8
-rw-r--r--science/netcdf4/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 13a6bf93e48..1270af16e61 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -24,6 +24,12 @@ INSTALLS_SHLIB= yes
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3 netcdf.3f
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-build:
@(cd ${WRKSRC}/libsrc && \
${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
@@ -36,4 +42,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index 13a6bf93e48..1270af16e61 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -24,6 +24,12 @@ INSTALLS_SHLIB= yes
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3 netcdf.3f
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-build:
@(cd ${WRKSRC}/libsrc && \
${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
@@ -36,4 +42,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>