aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-08-20 12:30:14 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-08-20 12:30:14 +0800
commitb58b1f5aa35f1f823a43b177c2200af552028d02 (patch)
tree44f7d9b0bd2a01be0192825d03d75a08cef3bf5e /science
parent502479a3a84ea977413e89e0c2fc61ace38be042 (diff)
downloadfreebsd-ports-graphics-b58b1f5aa35f1f823a43b177c2200af552028d02.tar.gz
freebsd-ports-graphics-b58b1f5aa35f1f823a43b177c2200af552028d02.tar.zst
freebsd-ports-graphics-b58b1f5aa35f1f823a43b177c2200af552028d02.zip
- Convert to new options dependency and target helper
- Remove PORTSCOUT
Diffstat (limited to 'science')
-rw-r--r--science/netcdf/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 4278a660ed5..c6ca23e39dc 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -15,7 +15,6 @@ COMMENT= C library for machine-independent, array-oriented data access
LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
CONFLICTS_INSTALL= hdf-4.[0-9]* netcdf-3.[0-9]* netcdf3-3.[0-9]*
-PORTSCOUT= limit:^4\.
OPTIONS_DEFINE= DAP DOCS DOXYGEN SZIP
OPTIONS_DEFAULT=DAP SZIP
@@ -36,26 +35,21 @@ DAP_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
DOXYGEN_CONFIGURE_OFF= --disable-doxygen
DOXYGEN_CONFIGURE_ON= --enable-doxygen
+DOXYGEN_IMPLIES= DOCS
DOXYGEN_PORTDOCS= *
SZIP_LIB_DEPENDS= libsz.so:${PORTSDIR}/science/szip
SZIP_LIBS= -lsz
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldl ||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mmap|_&|g' ${WRKSRC}/nc_test/tst_diskless.c ${WRKSRC}/nc_test/tst_diskless3.c
-post-build:
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
+post-build-DOXYGEN-on:
cd ${WRKSRC}/docs/ && ${LOCALBASE}/bin/doxygen .
-.endif
-post-install:
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
+post-install-DOXYGEN-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/docs/html/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-.endif
regression-test test: build
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check