aboutsummaryrefslogtreecommitdiffstats
path: root/security/akmos
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-03-24 19:01:18 +0800
committerrakuco <rakuco@FreeBSD.org>2016-03-24 19:01:18 +0800
commitbf5cd96522eef2622dd9aef64758aab8c6f1aabb (patch)
tree9fe44ad695a4d6515250cb2f8cd771affc8c7218 /security/akmos
parent63c137b4c9cc89f05cbdef6e6748a479aaab2e18 (diff)
downloadfreebsd-ports-graphics-bf5cd96522eef2622dd9aef64758aab8c6f1aabb.tar.gz
freebsd-ports-graphics-bf5cd96522eef2622dd9aef64758aab8c6f1aabb.tar.zst
freebsd-ports-graphics-bf5cd96522eef2622dd9aef64758aab8c6f1aabb.zip
New port: security/akmos.
Akmos is a cryptographic library with CLI. It supports: - symmetric ciphering; - computing message digests (hashes); - calculating a message authentication code (MAC); Depends only on the standard C library. Primary develop for the x86_64 architecture. WWW: https://github.com/melanhit/akmos PR: 206987 Submitted by: Andrew Romanenko <melanhit@gmail.com>
Diffstat (limited to 'security/akmos')
-rw-r--r--security/akmos/Makefile31
-rw-r--r--security/akmos/distinfo2
-rw-r--r--security/akmos/pkg-descr11
-rw-r--r--security/akmos/pkg-plist7
4 files changed, 51 insertions, 0 deletions
diff --git a/security/akmos/Makefile b/security/akmos/Makefile
new file mode 100644
index 00000000000..47357eaa273
--- /dev/null
+++ b/security/akmos/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= akmos
+PORTVERSION= 0.5.1
+CATEGORIES= security
+
+MAINTAINER= melanhit@gmail.com
+COMMENT= Cryptographic library with low footprint
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= melanhit
+GH_PROJECT= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+USES= cmake:outsource
+
+OPTIONS_DEFINE= ASM TEST
+OPTIONS_DEFAULT=ASM
+
+ASM_CMAKE_ON= -DAKMOS_USE_ASM:BOOL=TRUE
+ASM_CMAKE_OFF= -DAKMOS_USE_ASM:BOOL=FALSE
+
+TEST_CMAKE_ON= -DAKMOS_ENABLE_TEST:BOOL=TRUE
+TEST_CMAKE_OFF= -DAKMOS_ENABLE_TEST:BOOL=FALSE
+
+.include <bsd.port.mk>
diff --git a/security/akmos/distinfo b/security/akmos/distinfo
new file mode 100644
index 00000000000..79e91258cbf
--- /dev/null
+++ b/security/akmos/distinfo
@@ -0,0 +1,2 @@
+SHA256 (melanhit-akmos-0.5.1_GH0.tar.gz) = 627346aa85352140894bed490ebd840f6cc563316f0b544bf6b48e7017d0dd9f
+SIZE (melanhit-akmos-0.5.1_GH0.tar.gz) = 165208
diff --git a/security/akmos/pkg-descr b/security/akmos/pkg-descr
new file mode 100644
index 00000000000..24da38721a4
--- /dev/null
+++ b/security/akmos/pkg-descr
@@ -0,0 +1,11 @@
+Akmos is a cryptographic library with CLI.
+
+It supports:
+- symmetric ciphering;
+- computing message digests (hashes);
+- calculating a message authentication code (MAC);
+
+Depends only on the standard C library.
+Primary develop for the x86_64 architecture.
+
+WWW: https://github.com/melanhit/akmos
diff --git a/security/akmos/pkg-plist b/security/akmos/pkg-plist
new file mode 100644
index 00000000000..09b685396a8
--- /dev/null
+++ b/security/akmos/pkg-plist
@@ -0,0 +1,7 @@
+bin/akmos
+include/akmos.h
+lib/libakmos.a
+lib/libakmos.so
+lib/libakmos.so.5
+lib/libakmos.so.0.5
+man/man1/akmos.1.gz