aboutsummaryrefslogtreecommitdiffstats
path: root/security/authforce
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-12-13 20:41:35 +0800
committerroam <roam@FreeBSD.org>2006-12-13 20:41:35 +0800
commitde4cf73f5446a2a8a2c782e21edd36968046a9e7 (patch)
treea8af6bc7bac65179902c59b7a1f9ab026c6203c4 /security/authforce
parentf6df9e67cbe8aa509adda747e0c3bcbe05c8c99b (diff)
downloadfreebsd-ports-graphics-de4cf73f5446a2a8a2c782e21edd36968046a9e7.tar.gz
freebsd-ports-graphics-de4cf73f5446a2a8a2c782e21edd36968046a9e7.tar.zst
freebsd-ports-graphics-de4cf73f5446a2a8a2c782e21edd36968046a9e7.zip
Update the ftp/curl port to 7.16.0.
Bump PORTREVISION of all dependent ports. Fix the build errors in the few ports that still use the long deprecated, and now obsoleted, cURL options. Thanks to everyone who took the time to look over the patch! Discussed on: -ports
Diffstat (limited to 'security/authforce')
-rw-r--r--security/authforce/Makefile4
-rw-r--r--security/authforce/files/patch-ae12
2 files changed, 14 insertions, 2 deletions
diff --git a/security/authforce/Makefile b/security/authforce/Makefile
index 27fd7b5213f..9b8cdef9ee8 100644
--- a/security/authforce/Makefile
+++ b/security/authforce/Makefile
@@ -7,14 +7,14 @@
PORTNAME= authforce
PORTVERSION= 0.9.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security www
MASTER_SITES= http://www.divineinvasion.net/authforce/
MAINTAINER= ache@FreeBSD.org
COMMENT= HTTP authentication brute forcer
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
USE_GETOPT_LONG=yes
diff --git a/security/authforce/files/patch-ae b/security/authforce/files/patch-ae
new file mode 100644
index 00000000000..33a04ebcca4
--- /dev/null
+++ b/security/authforce/files/patch-ae
@@ -0,0 +1,12 @@
+--- src/http.c.orig Tue Dec 5 16:06:36 2006
++++ src/http.c Tue Dec 5 16:06:24 2006
+@@ -68,7 +68,9 @@
+ curl_easy_setopt(curl, CURLOPT_FAILONERROR, 1);
+ curl_easy_setopt(curl, CURLOPT_USERPWD, authstring);
+ curl_easy_setopt(curl, CURLOPT_FOLLOWLOCATION, 1);
++#if LIBCURL_VERSION_NUM < 0x071000
+ curl_easy_setopt(curl, CURLOPT_MUTE, 1);
++#endif
+ curl_easy_setopt(curl, CURLOPT_NOPROGRESS, 1);
+ curl_easy_setopt(curl, CURLOPT_USERAGENT, user_agent);
+ if (strcmp(proxy, "undef"))