aboutsummaryrefslogtreecommitdiffstats
path: root/security/autossh
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-10-07 07:49:25 +0800
committerleeym <leeym@FreeBSD.org>2003-10-07 07:49:25 +0800
commit860b4aafec310ea35a30a583e31a62fd02fdeb9f (patch)
treee3507117ae3fdf9a5afc5150f0b2511137da8563 /security/autossh
parenta1afe84b7f3236802becaf71f33042f004ea778f (diff)
downloadfreebsd-ports-graphics-860b4aafec310ea35a30a583e31a62fd02fdeb9f.tar.gz
freebsd-ports-graphics-860b4aafec310ea35a30a583e31a62fd02fdeb9f.tar.zst
freebsd-ports-graphics-860b4aafec310ea35a30a583e31a62fd02fdeb9f.zip
add autossh-1.2d
autossh is a program to start a copy of ssh and monitor it, restarting it as necessary should it die or stop passing traffic. The original idea and the mechanism were from rstunnel (Reliable SSH Tunnel). With this version the method changes: autossh uses ssh to construct a loop of ssh forwardings (one from local to remote, one from remote to local), and then sends test data that it expects to get back. (The idea is thanks to Terrence Martin.) WWW: http://www.harding.motd.ca/autossh/
Diffstat (limited to 'security/autossh')
-rw-r--r--security/autossh/Makefile27
-rw-r--r--security/autossh/distinfo1
-rw-r--r--security/autossh/pkg-descr10
-rw-r--r--security/autossh/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/security/autossh/Makefile b/security/autossh/Makefile
new file mode 100644
index 00000000000..4e077696c0f
--- /dev/null
+++ b/security/autossh/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: autossh
+# Date created: 26 December 2002
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autossh
+PORTVERSION= 1.2d
+CATEGORIES= security
+MASTER_SITES= http://www.harding.motd.ca/autossh/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Automatically restart SSH sessions and tunnels
+
+MAKEFILE= Makefile.bsd
+USE_REINPLACE= yes
+
+MAN1= autossh.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,cp autossh.1 ,$$\{BSD_INSTALL_MAN\} autossh.1 ,g' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's,cp autossh ,$$\{BSD_INSTALL_PROGRAM\} autossh ,g' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's,cp ,$$\{BSD_INSTALL_DATA\} ,g' ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/security/autossh/distinfo b/security/autossh/distinfo
new file mode 100644
index 00000000000..d4285e9aec1
--- /dev/null
+++ b/security/autossh/distinfo
@@ -0,0 +1 @@
+MD5 (autossh-1.2d.tgz) = 6e73d325a8286ac3d8eddf63f2043d0d
diff --git a/security/autossh/pkg-descr b/security/autossh/pkg-descr
new file mode 100644
index 00000000000..d696b954832
--- /dev/null
+++ b/security/autossh/pkg-descr
@@ -0,0 +1,10 @@
+autossh is a program to start a copy of ssh and monitor it, restarting
+it as necessary should it die or stop passing traffic.
+
+The original idea and the mechanism were from rstunnel (Reliable SSH
+Tunnel). With this version the method changes: autossh uses ssh to
+construct a loop of ssh forwardings (one from local to remote, one
+from remote to local), and then sends test data that it expects to
+get back. (The idea is thanks to Terrence Martin.)
+
+WWW: http://www.harding.motd.ca/autossh/
diff --git a/security/autossh/pkg-plist b/security/autossh/pkg-plist
new file mode 100644
index 00000000000..e4532cafc28
--- /dev/null
+++ b/security/autossh/pkg-plist
@@ -0,0 +1,5 @@
+bin/autossh
+%%DOCSDIR%%/CHANGES
+%%DOCSDIR%%/README
+%%EXAMPLESDIR%%/autossh.host
+%%EXAMPLESDIR%%/rscreen