aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-07-07 15:37:08 +0800
committernork <nork@FreeBSD.org>2003-07-07 15:37:08 +0800
commitb609a0d2c999bcfe70f03185d24d9832ca8fb994 (patch)
treef7a66b35423091046509c0bfd6e77778f23cb603 /security/clamav
parenta6353961d929d772585c78606c76fccfdc3abf94 (diff)
downloadfreebsd-ports-graphics-b609a0d2c999bcfe70f03185d24d9832ca8fb994.tar.gz
freebsd-ports-graphics-b609a0d2c999bcfe70f03185d24d9832ca8fb994.tar.zst
freebsd-ports-graphics-b609a0d2c999bcfe70f03185d24d9832ca8fb994.zip
Use clamav-milter, but support only gcc30 or higher.
PR: ports/53699 Submitted by: Rob Evers <rob@debank.tv> Approved by: TERAMOTO Masahiro <markun@onohara.to> (maintainer)
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile8
-rw-r--r--security/clamav/pkg-descr2
-rw-r--r--security/clamav/pkg-plist1
3 files changed, 11 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 9f1a412b6d6..9410673f396 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.60
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://clamav.elektrapro.com/stable/ \
http://clamav.essentkabel.com/stable/
@@ -37,6 +38,13 @@ MAN8= clamd.8
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 500000
+CONFIGURE_ARGS+=--enable-milter
+PLIST_SUB+= CLAMAV-MILTER:=""
+.else
+PLIST_SUB+= CLAMAV-MILTER:="@comment "
+.endif
+
pre-install:
@${ECHO} "===> Creating custom user to run clamav..."
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
diff --git a/security/clamav/pkg-descr b/security/clamav/pkg-descr
index 46864334476..af63f4e19c0 100644
--- a/security/clamav/pkg-descr
+++ b/security/clamav/pkg-descr
@@ -1,3 +1,5 @@
Clam Antivirus is command line virus scanner written entirely in C
and its database is kept up to date. It also detects polymorphic
viruses, scans compressed files and supported by AMaViS.
+On FreeBSD 4.X the milter interface isn't built by default because
+it needs gcc30 or higher.
diff --git a/security/clamav/pkg-plist b/security/clamav/pkg-plist
index 4cc7f7d00c9..cac5ce5be29 100644
--- a/security/clamav/pkg-plist
+++ b/security/clamav/pkg-plist
@@ -2,6 +2,7 @@ bin/clamscan
bin/clamdscan
bin/freshclam
bin/sigtool
+%%CLAMAV-MILTER:%%sbin/clamav-milter
sbin/clamd
include/clamav.h
lib/libclamav.so.1