aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-06-09 00:16:49 +0800
committerleeym <leeym@FreeBSD.org>2003-06-09 00:16:49 +0800
commitcd0c654fabd64a940cf308427a09c01d53ab58de (patch)
tree81676fff813ddb251656e0d4604213271ed064ad /security/clamav
parent7622d5ad94f7224c8617e2786a256f2ab1db4b68 (diff)
downloadfreebsd-ports-graphics-cd0c654fabd64a940cf308427a09c01d53ab58de.tar.gz
freebsd-ports-graphics-cd0c654fabd64a940cf308427a09c01d53ab58de.tar.zst
freebsd-ports-graphics-cd0c654fabd64a940cf308427a09c01d53ab58de.zip
Enable pthread support using devel/pth.
Turn on building clamd and clamdscan. PR: 53056 Pointed out by: Olivier Tharan <olive@oban.frmug.org> Submitted by: TERAMOTO Masahiro <markun@onohara.to>
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile6
-rw-r--r--security/clamav/pkg-install4
-rw-r--r--security/clamav/pkg-plist2
3 files changed, 8 insertions, 4 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 4fe6a4c4912..7d7704382fa 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -19,11 +19,13 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
zoo:${PORTSDIR}/archivers/zoo \
arc:${PORTSDIR}/archivers/arc \
unzip:${PORTSDIR}/archivers/unzip
+LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth
USE_GMAKE= yes
-HAS_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --disable-clamav --disable-pthreads
+CONFIGURE_ARGS= --prefix=${PREFIX} --disable-clamav
MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1
MAN5= clamav.conf.5
diff --git a/security/clamav/pkg-install b/security/clamav/pkg-install
index 448ffdc1f34..4e257bc4ccf 100644
--- a/security/clamav/pkg-install
+++ b/security/clamav/pkg-install
@@ -4,8 +4,8 @@ if [ "$2" != "PRE-INSTALL" ]; then
exit 0
fi
-USER=clamav
-GROUP=clamav
+USER?=clamav
+GROUP?=clamav
if ! pw groupshow "$GROUP" 2>/dev/null 1>&2; then
if pw groupadd $GROUP; then
diff --git a/security/clamav/pkg-plist b/security/clamav/pkg-plist
index 078a2b5937b..b919db1eb40 100644
--- a/security/clamav/pkg-plist
+++ b/security/clamav/pkg-plist
@@ -1,6 +1,8 @@
bin/clamscan
+bin/clamdscan
bin/freshclam
bin/sigtool
+sbin/clamd
include/clamav.h
lib/libclamav.so.1
lib/libclamav.so