aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-23 21:08:06 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-23 21:08:06 +0800
commitf1d746f516ac325edd5434f6be595a8f1d09b52f (patch)
tree69f7e8a7b40a979ba138443f005dd53370315a1b /security/clamav
parent2c81e48875d63bf5843eaa0f7d0259407bfdc416 (diff)
downloadfreebsd-ports-graphics-f1d746f516ac325edd5434f6be595a8f1d09b52f.tar.gz
freebsd-ports-graphics-f1d746f516ac325edd5434f6be595a8f1d09b52f.tar.zst
freebsd-ports-graphics-f1d746f516ac325edd5434f6be595a8f1d09b52f.zip
- Fix compilation of the milter interface [1]
- Unconditionally define PORTDOCS, as bsd.port.mk now tests ${NOPORTDOCS} [1]: PR: ports/82543 Submitted by: Thomas Abthorpe <thomas@stthomasanglican.org>
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile2
-rw-r--r--security/clamav/files/patch-configure17
2 files changed, 13 insertions, 6 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 4b480da3efe..a357b4317e2 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -30,9 +30,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
USE_RC_SUBR= yes
-.if !defined(NOPORTDOCS)
PORTDOCS= NEWS ChangeLog html
-.endif
DBDIR= /var/db/clamav
LOGDIR= /var/log/clamav
diff --git a/security/clamav/files/patch-configure b/security/clamav/files/patch-configure
index 7b51d37436e..c98d492aee0 100644
--- a/security/clamav/files/patch-configure
+++ b/security/clamav/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Mar 15 21:04:49 2004
-+++ configure Thu Apr 1 14:56:36 2004
-@@ -10635,6 +10635,9 @@
+--- configure.orig Sun Jun 19 21:56:23 2005
++++ configure Thu Jun 23 14:57:09 2005
+@@ -10914,6 +10914,9 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
@@ -10,7 +10,7 @@
#include <resolv.h>
_ACEOF
rm -f conftest.$ac_objext
-@@ -10678,6 +10681,9 @@
+@@ -10957,6 +10960,9 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@@ -20,3 +20,12 @@
#include <resolv.h>
_ACEOF
if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+@@ -13267,7 +13273,7 @@
+ # Check whether --enable-gethostbyname_r or --disable-gethostbyname_r was given.
+ if test "${enable_gethostbyname_r+set}" = set; then
+ enableval="$enable_gethostbyname_r"
+- disable_gethostbyname_r=$enableval
++ test $enableval = yes && disable_gethostbyname_r=no || disable_gethostbyname_r=yes
+ fi;
+
+ if test "$disable_gethostbyname_r" = "yes"; then