aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2-saslauthd
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2004-01-17 23:35:34 +0800
committerume <ume@FreeBSD.org>2004-01-17 23:35:34 +0800
commitf273bc749c4fdc363720ec9dac35969d7c5dbccd (patch)
treecdcab9109e15176ea407d77127c29932e0f05deb /security/cyrus-sasl2-saslauthd
parent2a6720e965f851522bf0df20eaecfa86cdebbf28 (diff)
downloadfreebsd-ports-graphics-f273bc749c4fdc363720ec9dac35969d7c5dbccd.tar.gz
freebsd-ports-graphics-f273bc749c4fdc363720ec9dac35969d7c5dbccd.tar.zst
freebsd-ports-graphics-f273bc749c4fdc363720ec9dac35969d7c5dbccd.zip
Support Berkeley DB 4.2.
Since our db42 requires to include db.h to use. existing configure script cannot detect our db42. AC_CHECK_LIB() simply test if a function exists. :( Requested by: Dmitry Sorokin <dmitry_sorokin@yahoo.ca>
Diffstat (limited to 'security/cyrus-sasl2-saslauthd')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 0fe99c22aa9..bdbaf815cd4 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -45,17 +45,20 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-saslauthd
.if defined(WITH_BDB_VER)
-.if ${WITH_BDB_VER} == 41
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS+=--with-bdb=db41 --with-bdb-incdir=${PREFIX}/include/db41
+.if ${WITH_BDB_VER} == 3
+LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
+CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db3 --with-bdb=db3
.elif ${WITH_BDB_VER} == 4
LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-CONFIGURE_ARGS+=--with-bdb=db4 --with-bdb-incdir=${PREFIX}/include/db4
-.elif ${WITH_BDB_VER} == 3
-LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
-CONFIGURE_ARGS+=--with-bdb=db3 --with-bdb-incdir=${PREFIX}/include/db3
+CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db4 --with-bdb=db4
+.elif ${WITH_BDB_VER} == 41
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
+CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db41 --with-bdb=db41
+.elif ${WITH_BDB_VER} == 42
+LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
+CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db42 --with-bdb=db-4.2
.else
-BROKEN= "WITH_BDB_VER must be 3, 4 or 41"
+BROKEN= "WITH_BDB_VER must be 3, 4, 41 or 42"
.endif
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${PREFIX}/lib
.else