aboutsummaryrefslogtreecommitdiffstats
path: root/security/dcetest
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /security/dcetest
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-graphics-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-graphics-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-graphics-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'security/dcetest')
-rw-r--r--security/dcetest/Makefile3
-rw-r--r--security/dcetest/files/patch-Makefile4
-rw-r--r--security/dcetest/files/patch-dcetest.c22
-rw-r--r--security/dcetest/files/patch-tcpstuff.c10
-rw-r--r--security/dcetest/files/patch-tcpstuff.h6
5 files changed, 24 insertions, 21 deletions
diff --git a/security/dcetest/Makefile b/security/dcetest/Makefile
index aa52beb7575..46d9cf209b7 100644
--- a/security/dcetest/Makefile
+++ b/security/dcetest/Makefile
@@ -9,6 +9,9 @@ MASTER_SITES= PACKETSTORM/UNIX/scanners
MAINTAINER= onatan@gmail.com
COMMENT= Utility to dump MSRPC endpoint information from Windows systems
+USES= dos2unix
+DOS2UNIX_GLOB= *.c
+
ALL_TARGET= dcetest
MAKE_ARGS= CC="${CC}"
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/security/dcetest/files/patch-Makefile b/security/dcetest/files/patch-Makefile
index 9a12138dcf3..30349d5cd21 100644
--- a/security/dcetest/files/patch-Makefile
+++ b/security/dcetest/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Jan 11 06:22:46 2003
-+++ Makefile Sat Jan 11 06:23:10 2003
+--- Makefile.orig 2001-08-20 20:40:40 UTC
++++ Makefile
@@ -1,6 +1,6 @@
.SUFFIXES: .a .o .c
CC = gcc
diff --git a/security/dcetest/files/patch-dcetest.c b/security/dcetest/files/patch-dcetest.c
index 23347da6137..d5bc9b507c0 100644
--- a/security/dcetest/files/patch-dcetest.c
+++ b/security/dcetest/files/patch-dcetest.c
@@ -1,11 +1,11 @@
---- dcetest.c.orig Tue Feb 15 11:32:36 2005
-+++ dcetest.c Tue Feb 15 11:31:48 2005
-@@ -359,7 +359,7 @@
- int tint;
- char annotation[EPT_MAX_ANNOTATION_SIZE+1];
- int floor, floors;
-- int address_type;
-+ int address_type=0;
-
- char tmp_address[200];
- char tmp_address2[200];
+--- dcetest.c.orig 2016-06-20 15:23:56 UTC
++++ dcetest.c
+@@ -359,7 +359,7 @@ dce_parse_enum_response(const unsigned c
+ int tint;
+ char annotation[EPT_MAX_ANNOTATION_SIZE+1];
+ int floor, floors;
+- int address_type;
++ int address_type=0;
+
+ char tmp_address[200];
+ char tmp_address2[200];
diff --git a/security/dcetest/files/patch-tcpstuff.c b/security/dcetest/files/patch-tcpstuff.c
index d05de6c8575..4abe4a65547 100644
--- a/security/dcetest/files/patch-tcpstuff.c
+++ b/security/dcetest/files/patch-tcpstuff.c
@@ -1,6 +1,6 @@
---- tcpstuff.c.orig Sat Jan 11 06:46:08 2003
-+++ tcpstuff.c Sat Jan 11 06:50:59 2003
-@@ -229,6 +229,7 @@
+--- tcpstuff.c.orig 2016-06-20 15:23:56 UTC
++++ tcpstuff.c
+@@ -229,6 +229,7 @@ make_tcp_listener(unsigned short localpo
/* this function takes in a listenFd and returns an acceptedFd */
@@ -8,7 +8,7 @@
int
tcp_accept(int listenFd)
{
-@@ -242,12 +243,14 @@
+@@ -242,12 +243,14 @@ tcp_accept(int listenFd)
(struct sockaddr *)&clientAddr,
&addrLen)) < 0)
{
@@ -25,7 +25,7 @@
lingerVal.l_onoff = 0;
lingerVal.l_linger = 0;
if (setsockopt(clientFd, SOL_SOCKET, SO_LINGER,
-@@ -260,3 +263,4 @@
+@@ -260,3 +263,4 @@ tcp_accept(int listenFd)
return(clientFd);
}
diff --git a/security/dcetest/files/patch-tcpstuff.h b/security/dcetest/files/patch-tcpstuff.h
index 16571912374..152ac0e6d1f 100644
--- a/security/dcetest/files/patch-tcpstuff.h
+++ b/security/dcetest/files/patch-tcpstuff.h
@@ -1,6 +1,6 @@
---- tcpstuff.h.orig Sat Jan 11 06:48:15 2003
-+++ tcpstuff.h Sat Jan 11 06:48:54 2003
-@@ -42,5 +42,7 @@
+--- tcpstuff.h.orig 2001-08-20 20:29:56 UTC
++++ tcpstuff.h
+@@ -42,5 +42,7 @@ make_tcp_listener(unsigned short localpo
int
write_uint32(int fd,uint32 data);