aboutsummaryrefslogtreecommitdiffstats
path: root/security/ddos_scan/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-02-14 09:58:38 +0800
committerobrien <obrien@FreeBSD.org>2000-02-14 09:58:38 +0800
commit6f8a8ce08140241bd37a729396b7930f5f4ef083 (patch)
tree3548f652aec0734ebe0a479985f5514f943b31f2 /security/ddos_scan/Makefile
parent4f62da2f3fbb426d4e0e7551b167adcc815bb8c6 (diff)
downloadfreebsd-ports-graphics-6f8a8ce08140241bd37a729396b7930f5f4ef083.tar.gz
freebsd-ports-graphics-6f8a8ce08140241bd37a729396b7930f5f4ef083.tar.zst
freebsd-ports-graphics-6f8a8ce08140241bd37a729396b7930f5f4ef083.zip
"dds" is a program to scan for a limited set of distributed denial of
service (ddos) agents. At present, it scans for active instances of "trinoo", "Tribe Flood Network" ("TFN") and "stacheldraht" agents, which were compiled using the default values in known source distributions. It will *not* detect TFN2K agents.
Diffstat (limited to 'security/ddos_scan/Makefile')
-rw-r--r--security/ddos_scan/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/ddos_scan/Makefile b/security/ddos_scan/Makefile
new file mode 100644
index 00000000000..5081e8e14d0
--- /dev/null
+++ b/security/ddos_scan/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: ddos_scan
+# Version required: 1.6
+# Date created: Sun Feb 12, 2000
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+DISTNAME= ddos_scan
+PKGNAME= ddos_scan-1.6
+CATEGORIES= security
+MASTER_SITES= http://staff.washington.edu/dittrich/misc/
+EXTRACT_SUFX= .tar
+
+MAINTAINER= obrien@FreeBSD.org
+
+ALL_TARGET= dds
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/dds ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/ddos_scan
+ @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/ddos_scan
+.endif
+
+.include <bsd.port.mk>