aboutsummaryrefslogtreecommitdiffstats
path: root/security/fiked
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
committerpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
commitccd12ccd577604add511aad4ea4e71c32b3e2f06 (patch)
tree25b833c135dd7f2323045f819dc7121e621103fc /security/fiked
parente2f15954f8960a944e8d5b2c28982257d8c6e91f (diff)
downloadfreebsd-ports-graphics-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.gz
freebsd-ports-graphics-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.zst
freebsd-ports-graphics-ccd12ccd577604add511aad4ea4e71c32b3e2f06.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Diffstat (limited to 'security/fiked')
-rw-r--r--security/fiked/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/fiked/Makefile b/security/fiked/Makefile
index 7e992dbe089..fb6c8b874c5 100644
--- a/security/fiked/Makefile
+++ b/security/fiked/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fiked
PORTVERSION= 0.0.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://dragon.roe.ch/bitsnpieces/fiked/ \
http://home.tiscalinet.ch/roe/fiked/
@@ -16,7 +17,7 @@ COMMENT= A fake IKE PSK+XAUTH daemon based on VPNC
LIB_DEPENDS= gcrypt.13:${PORTSDIR}/security/libgcrypt
.if !defined(WITHOUT_LIBNET)
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
.endif
USE_BZIP2= yes
@@ -29,8 +30,14 @@ PLIST_FILES= bin/fiked
MAN1= fiked.1
PORTDOCS= README NEWS
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
post-patch:
- @${REINPLACE_CMD} -e 's|=-g|=|' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e \
+ 's|=-g|=|; \
+ s|-lnet|`${LIBNET_CONFIG} --libs`|; \
+ s|-DWITH_LIBNET|& `${LIBNET_CONFIG} --cflags`|' \
+ ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fiked ${PREFIX}/bin