aboutsummaryrefslogtreecommitdiffstats
path: root/security/fragroute
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2006-07-04 23:44:53 +0800
committerstefan <stefan@FreeBSD.org>2006-07-04 23:44:53 +0800
commitd69245f76643da79eed406ae515b469aac20efaf (patch)
treee2ee95c03b90d31f3a568c8618a76ec9450eb78b /security/fragroute
parent2a4f817f9cf80618f6f3661bae3ba691ffc9a825 (diff)
downloadfreebsd-ports-graphics-d69245f76643da79eed406ae515b469aac20efaf.tar.gz
freebsd-ports-graphics-d69245f76643da79eed406ae515b469aac20efaf.tar.zst
freebsd-ports-graphics-d69245f76643da79eed406ae515b469aac20efaf.zip
- Replace the BUILD_DEPENDS by LIB_DEPENDS on libdnet and libevent.
- Point configure at ${LOCALBASE} instead of ${PREFIX} when looking for the libraries. - Use ${DATADIR} where appropriate. PR: 99619 Submitted by: Richard Bejtlich <taosecurity@gmail.com> Patch by: stefan Approved by: maintainer arved (mentor)
Diffstat (limited to 'security/fragroute')
-rw-r--r--security/fragroute/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/security/fragroute/Makefile b/security/fragroute/Makefile
index 9e34afb824f..ce110eb1b3b 100644
--- a/security/fragroute/Makefile
+++ b/security/fragroute/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fragroute
PORTVERSION= 1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security net
MASTER_SITES= http://monkey.org/~dugsong/fragroute/ \
${MASTER_SITE_PACKETSTORM}
@@ -16,12 +16,12 @@ MASTER_SITE_SUBDIR= UNIX/security
MAINTAINER= onatan@gmail.com
COMMENT= A tool for intercepting, modifying and rewriting egress traffic
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
- ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet \
+ event-1:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-libdnet=${PREFIX} \
- --with-libevent=${PREFIX} --with-pcap
+CONFIGURE_ARGS+= --with-libdnet=${LOCALBASE} \
+ --with-libevent=${LOCALBASE} --with-pcap
MAN8= fragroute.8 fragtest.8
@@ -30,10 +30,9 @@ SCRIPTS= README.snort base-1 frag-1 frag-2 frag-3 frag-4 frag-5 \
tcp-7 tcp-9
pre-install:
- ${MKDIR} ${PREFIX}/share/${PORTNAME}
+ ${MKDIR} ${DATADIR}
.for FILE in ${SCRIPTS}
- ${INSTALL_DATA} ${WRKSRC}/scripts/${FILE} \
- ${PREFIX}/share/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/scripts/${FILE} ${DATADIR}
.endfor
.include <bsd.port.mk>