aboutsummaryrefslogtreecommitdiffstats
path: root/security/gcipher
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
committermarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
commit43bd9f14d9ce11690e9538bf3b03d3462faa6dbe (patch)
treeda347910089a96d6d726b8bb080f62c773263828 /security/gcipher
parent2e669ed08a56339ee1a8b2a0573a30147f95bd82 (diff)
downloadfreebsd-ports-graphics-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.gz
freebsd-ports-graphics-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.zst
freebsd-ports-graphics-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.zip
Presenting GNOME 2.20.1 and all related works for FreeBSD. The official
GNOME 2.20 release notes can be found at http://www.gnome.org/start/2.20/notes/en/ . Beyond that, this update includes the new GIMP 2.4 (courtesy of ahze). The GNOME 2.20 update also includes a huge change in the FreeBSD GNOME hierarchy. We are now using the more standard DATADIR of ${PREFIX}/share rather than ${PREFIX}/share/gnome. The result is that fewer patches and hacks are needed to port GNOME components to FreeBSD. This will mean some user changes may be required, so be sure to read /usr/ports/UPDATING for more details. This release and the things we accomplished in it would not have been possible without mezz's crazy idea to collapse DATADIR, and his persistence to make it happen successfully. Ahze and pav also deserve thanks for their work on porting modules and testing the whole ball of wax on pointyhat (respectively). The FreeBSD GNOME team would also like to thank our various testers and contributors: Yasuda Keisuke Frank Jahnke Pawel Worach Brian Gruber Franz Klammer Yuri Pankov Nick Barkas Cristian KLEIN Tony Maher Scot Hetzel Martin Matuska (mm) Benoit Dejean Martin Wilke (miwi) (And anyone else I may have missed) PRs fixed in this release: 111272, 113470, 115995, 116338
Diffstat (limited to 'security/gcipher')
-rw-r--r--security/gcipher/Makefile10
-rw-r--r--security/gcipher/files/patch-Const.py2
-rw-r--r--security/gcipher/files/patch-gcipher2
-rw-r--r--security/gcipher/files/patch-gcipher.desktop2
-rw-r--r--security/gcipher/pkg-plist129
5 files changed, 75 insertions, 70 deletions
diff --git a/security/gcipher/Makefile b/security/gcipher/Makefile
index 6825fb54f90..ef1681c30d3 100644
--- a/security/gcipher/Makefile
+++ b/security/gcipher/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcipher
PORTVERSION= 1.0
-PORTREVISION= 7
+PORTREVISION= 9
CATEGORIES= security gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,10 +21,14 @@ USE_PYTHON= yes
USE_XLIB= yes
USE_GNOME= libgnomeui
-GCIPHER_PREFIX= ${PREFIX}/share/gnome/gcipher
+GCIPHER_PREFIX= ${PREFIX}/share/gcipher
MAN1= gcipher.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/src/Const.py ${WRKSRC}/src/gcipher
+
do-build:
(cd ${WRKSRC}/src; \
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py .)
@@ -42,7 +46,7 @@ do-install:
(cd ${WRKSRC}/src; \
${INSTALL_SCRIPT} gcipher ${PREFIX}/bin/gcipher; \
- ${INSTALL_DATA} gcipher.desktop ${PREFIX}/share/gnome/applications; \
+ ${INSTALL_DATA} gcipher.desktop ${PREFIX}/share/applications; \
for i in `${FIND} . -name '*.py' \
-o -name '*.pyc' \
-o -name '*.glade' \
diff --git a/security/gcipher/files/patch-Const.py b/security/gcipher/files/patch-Const.py
index eac9b1ae6d1..b4b94da306d 100644
--- a/security/gcipher/files/patch-Const.py
+++ b/security/gcipher/files/patch-Const.py
@@ -6,4 +6,4 @@ diff -ur ../gcipher-1.0.orig/src/Const.py ./src/Const.py
as a command line filter or as a network proxy."""
AUTHORS = ["Shannon -jj Behrens <jjinux@yahoo.com>"]
-GLADEDIR = "."
-+GLADEDIR = "/usr/X11R6/share/gnome/gcipher/lib"
++GLADEDIR = "%%PREFIX%%/share/gcipher/lib"
diff --git a/security/gcipher/files/patch-gcipher b/security/gcipher/files/patch-gcipher
index cb48ac1009f..2e7ba1abc05 100644
--- a/security/gcipher/files/patch-gcipher
+++ b/security/gcipher/files/patch-gcipher
@@ -10,7 +10,7 @@ diff -ur ../gcipher-1.0.orig/src/gcipher ./src/gcipher
# Edit the path below if you need to port GCipher.
import sys
-# sys.path.append("/usr/share/gcipher/lib")
-+sys.path.append("/usr/X11R6/share/gnome/gcipher/lib")
++sys.path.append("%%PREFIX%%/share/gcipher/lib")
from os import environ
from os.path import join
diff --git a/security/gcipher/files/patch-gcipher.desktop b/security/gcipher/files/patch-gcipher.desktop
index 6027a262a8d..fa076993d6c 100644
--- a/security/gcipher/files/patch-gcipher.desktop
+++ b/security/gcipher/files/patch-gcipher.desktop
@@ -6,7 +6,7 @@ diff -ur ../gcipher-1.0.orig/src/gcipher.desktop ./src/gcipher.desktop
Comment[en_US.ISO8859-15]=A simple encryption tool
Exec=gcipher
-Icon=/usr/share/pixmaps/gnome-lockscreen.png
-+Icon=/usr/X11R6/share/gnome/pixmaps/gnome-lockscreen.png
++Icon=gnome-lockscreen.png
Terminal=false
Type=Application
StartupNotify=true
diff --git a/security/gcipher/pkg-plist b/security/gcipher/pkg-plist
index 640f01df3d0..2e0d6874038 100644
--- a/security/gcipher/pkg-plist
+++ b/security/gcipher/pkg-plist
@@ -1,65 +1,66 @@
bin/gcipher
-share/gnome/applications/gcipher.desktop
-share/gnome/gcipher/CONTRIB
-share/gnome/gcipher/LICENSE
-share/gnome/gcipher/README
-share/gnome/gcipher/lib/cipher/__init__.pyc
-share/gnome/gcipher/lib/cipher/Ceasar.py
-share/gnome/gcipher/lib/cipher/CharacterCipher.py
-share/gnome/gcipher/lib/cipher/Gie.py
-share/gnome/gcipher/lib/cipher/KeyedCipher.py
-share/gnome/gcipher/lib/cipher/Rot.py
-share/gnome/gcipher/lib/cipher/Tools.py
-share/gnome/gcipher/lib/cipher/Vigenere.py
-share/gnome/gcipher/lib/cipher/__init__.py
-share/gnome/gcipher/lib/cipher/KeyedCipher.pyc
-share/gnome/gcipher/lib/cipher/Vigenere.pyc
-share/gnome/gcipher/lib/cipher/CharacterCipher.pyc
-share/gnome/gcipher/lib/cipher/Tools.pyc
-share/gnome/gcipher/lib/cipher/Gie.pyc
-share/gnome/gcipher/lib/cipher/Ceasar.pyc
-share/gnome/gcipher/lib/cipher/Rot.pyc
-share/gnome/gcipher/lib/AutomaticClass.py
-share/gnome/gcipher/lib/Const.py
-share/gnome/gcipher/lib/GtkAttributesFacade.py
-share/gnome/gcipher/lib/LibGladeApplication.py
-share/gnome/gcipher/lib/MainCLI.py
-share/gnome/gcipher/lib/MainGUI.py
-share/gnome/gcipher/lib/Proxy.py
-share/gnome/gcipher/lib/gcipher.glade
-share/gnome/gcipher/lib/gcipher.gladep
-share/gnome/gcipher/lib/ciphergui/__init__.pyc
-share/gnome/gcipher/lib/ciphergui/Ceasar.py
-share/gnome/gcipher/lib/ciphergui/CipherGUIList.py
-share/gnome/gcipher/lib/ciphergui/Gie.py
-share/gnome/gcipher/lib/ciphergui/KeyDialog.py
-share/gnome/gcipher/lib/ciphergui/Rot.py
-share/gnome/gcipher/lib/ciphergui/Vigenere.py
-share/gnome/gcipher/lib/ciphergui/__init__.py
-share/gnome/gcipher/lib/ciphergui/rot.glade
-share/gnome/gcipher/lib/ciphergui/rot.gladep
-share/gnome/gcipher/lib/ciphergui/vigenere.glade
-share/gnome/gcipher/lib/ciphergui/vigenere.gladep
-share/gnome/gcipher/lib/ciphergui/CipherGUIList.pyc
-share/gnome/gcipher/lib/ciphergui/Vigenere.pyc
-share/gnome/gcipher/lib/ciphergui/KeyDialog.pyc
-share/gnome/gcipher/lib/ciphergui/Gie.pyc
-share/gnome/gcipher/lib/ciphergui/Ceasar.pyc
-share/gnome/gcipher/lib/ciphergui/Rot.pyc
-share/gnome/gcipher/lib/Const.pyc
-share/gnome/gcipher/lib/MainCLI.pyc
-share/gnome/gcipher/lib/AutomaticClass.pyc
-share/gnome/gcipher/lib/MainGUI.pyc
-share/gnome/gcipher/lib/LibGladeApplication.pyc
-share/gnome/gcipher/lib/GtkAttributesFacade.pyc
-share/gnome/gcipher/lib/Proxy.pyc
-share/gnome/gcipher/plugins/cipher/Identity.py
-share/gnome/gcipher/plugins/ciphergui/Identity.py
-share/gnome/gcipher/plugins/ciphergui/PluginCipherGUIList.py
-@dirrm share/gnome/gcipher/lib/cipher
-@dirrm share/gnome/gcipher/lib/ciphergui
-@dirrm share/gnome/gcipher/lib
-@dirrm share/gnome/gcipher/plugins/cipher
-@dirrm share/gnome/gcipher/plugins/ciphergui
-@dirrm share/gnome/gcipher/plugins
-@dirrm share/gnome/gcipher
+share/applications/gcipher.desktop
+share/gcipher/CONTRIB
+share/gcipher/LICENSE
+share/gcipher/README
+share/gcipher/lib/cipher/__init__.pyc
+share/gcipher/lib/cipher/Ceasar.py
+share/gcipher/lib/cipher/CharacterCipher.py
+share/gcipher/lib/cipher/Gie.py
+share/gcipher/lib/cipher/KeyedCipher.py
+share/gcipher/lib/cipher/Rot.py
+share/gcipher/lib/cipher/Tools.py
+share/gcipher/lib/cipher/Vigenere.py
+share/gcipher/lib/cipher/__init__.py
+share/gcipher/lib/cipher/KeyedCipher.pyc
+share/gcipher/lib/cipher/Vigenere.pyc
+share/gcipher/lib/cipher/CharacterCipher.pyc
+share/gcipher/lib/cipher/Tools.pyc
+share/gcipher/lib/cipher/Gie.pyc
+share/gcipher/lib/cipher/Ceasar.pyc
+share/gcipher/lib/cipher/Rot.pyc
+share/gcipher/lib/AutomaticClass.py
+share/gcipher/lib/Const.py
+share/gcipher/lib/GtkAttributesFacade.py
+share/gcipher/lib/LibGladeApplication.py
+share/gcipher/lib/MainCLI.py
+share/gcipher/lib/MainGUI.py
+share/gcipher/lib/Proxy.py
+share/gcipher/lib/gcipher.glade
+share/gcipher/lib/gcipher.gladep
+share/gcipher/lib/ciphergui/__init__.pyc
+share/gcipher/lib/ciphergui/Ceasar.py
+share/gcipher/lib/ciphergui/CipherGUIList.py
+share/gcipher/lib/ciphergui/Gie.py
+share/gcipher/lib/ciphergui/KeyDialog.py
+share/gcipher/lib/ciphergui/Rot.py
+share/gcipher/lib/ciphergui/Vigenere.py
+share/gcipher/lib/ciphergui/__init__.py
+share/gcipher/lib/ciphergui/rot.glade
+share/gcipher/lib/ciphergui/rot.gladep
+share/gcipher/lib/ciphergui/vigenere.glade
+share/gcipher/lib/ciphergui/vigenere.gladep
+share/gcipher/lib/ciphergui/CipherGUIList.pyc
+share/gcipher/lib/ciphergui/Vigenere.pyc
+share/gcipher/lib/ciphergui/KeyDialog.pyc
+share/gcipher/lib/ciphergui/Gie.pyc
+share/gcipher/lib/ciphergui/Ceasar.pyc
+share/gcipher/lib/ciphergui/Rot.pyc
+share/gcipher/lib/Const.pyc
+share/gcipher/lib/MainCLI.pyc
+share/gcipher/lib/AutomaticClass.pyc
+share/gcipher/lib/MainGUI.pyc
+share/gcipher/lib/LibGladeApplication.pyc
+share/gcipher/lib/GtkAttributesFacade.pyc
+share/gcipher/lib/Proxy.pyc
+share/gcipher/plugins/cipher/Identity.py
+share/gcipher/plugins/ciphergui/Identity.py
+share/gcipher/plugins/ciphergui/PluginCipherGUIList.py
+@dirrm share/gcipher/lib/cipher
+@dirrm share/gcipher/lib/ciphergui
+@dirrm share/gcipher/lib
+@dirrm share/gcipher/plugins/cipher
+@dirrm share/gcipher/plugins/ciphergui
+@dirrm share/gcipher/plugins
+@dirrm share/gcipher
+@dirrmtry share/applications