aboutsummaryrefslogtreecommitdiffstats
path: root/security/heimdal/Makefile
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2000-11-10 07:35:03 +0800
committernectar <nectar@FreeBSD.org>2000-11-10 07:35:03 +0800
commit3dcc64156840e7d176579cce36523e786a0c4b42 (patch)
tree3435f6fbaccfbc4b316d995de501785bb3ae1cb4 /security/heimdal/Makefile
parentafbfb6e94adf9bb0cf794ef2de9f68075a33e7e2 (diff)
downloadfreebsd-ports-graphics-3dcc64156840e7d176579cce36523e786a0c4b42.tar.gz
freebsd-ports-graphics-3dcc64156840e7d176579cce36523e786a0c4b42.tar.zst
freebsd-ports-graphics-3dcc64156840e7d176579cce36523e786a0c4b42.zip
= Use system libcom_err.
No longer build or install the included libcom_err and compile_et. = ftpd now uses IP_PORTRANGE* in the same fashion as the system ftpd. By default, ftpd will now use high port numbers for serving clients in passive mode. = Fix segmentation fault in kadmin. A null pointer dereference that was only tickled when using kadmin with a kdc that uses LDAP as the backend. = Fix a search filter in hdb-ldap.c. A lookup was failing to fetch operational attributes such as modifiersName. = Bump PORTREVISION for above changes.
Diffstat (limited to 'security/heimdal/Makefile')
-rw-r--r--security/heimdal/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 8fbe67c212d..d1ec0b74eac 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= heimdal
PORTVERSION= 0.3c
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.replay.com/pub/replay/crypto/APPS/kerberos/heimdal/ \
@@ -38,6 +38,7 @@ MAN8= ftpd.8 hprop.8 hpropd.8 kadmind.8 kdc.8 kfd.8 kpasswdd.8 \
#USE_LIBTOOL= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}--freebsd${OSREL}
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared
.if defined(WITH_LDAP)
@@ -69,6 +70,12 @@ CONFIGURE_ARGS+= --without-krb4
PLIST:= ${WRKDIR}/PLIST
+pre-configure:
+ @(set -e; \
+ cd ${CONFIGURE_WRKSRC}; \
+ find . -type f -name 'Makefile.in' -print | xargs perl -i -pe \
+ 's,\$$\(top_builddir\)/lib/com_err/compile_et,compile_et,';)
+
pre-install:
@${CP} ${PKGDIR}/pkg-plist ${PLIST}
.if exists(/usr/lib/libkrb.a) && !defined(WITHOUT_KRB4)