aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-tls
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 00:23:00 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 00:23:00 +0800
commit0a630c5f5083b825f1b1014861b1b3e36094fc59 (patch)
tree9280077d235d03b6b50a234aaa81bb661f0ecb4e /security/hs-tls
parentce0c86dceb6bf9a475e61aa1c34382d8f76500fe (diff)
downloadfreebsd-ports-graphics-0a630c5f5083b825f1b1014861b1b3e36094fc59.tar.gz
freebsd-ports-graphics-0a630c5f5083b825f1b1014861b1b3e36094fc59.tar.zst
freebsd-ports-graphics-0a630c5f5083b825f1b1014861b1b3e36094fc59.zip
Native Haskell TLS and SSL protocol implementation for server and
client. This provides a high-level implementation of a sensitive security protocol, eliminating a common set of security issues through the use of the advanced type system, high level constructions and common Haskell features. Currently implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, with only RSA supported for Key Exchange. WWW: http://github.com/vincenthz/hs-tls Obtained from: FreeBSD Haskell
Diffstat (limited to 'security/hs-tls')
-rw-r--r--security/hs-tls/Makefile36
-rw-r--r--security/hs-tls/distinfo2
-rw-r--r--security/hs-tls/pkg-descr12
3 files changed, 50 insertions, 0 deletions
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
new file mode 100644
index 00000000000..ee75beca082
--- /dev/null
+++ b/security/hs-tls/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: hs-tls
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tls
+PORTVERSION= 0.8.5
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= TLS/SSL protocol native implementation (server and client)
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= cereal>=0.3 certificate>=1.0.0 crypto-api>=0.5 \
+ cryptocipher>=0.3.0 cryptohash>=0.6 mtl
+
+OPTIONS= EXECUTABLE "Build the executables" off
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+.include <bsd.port.options.mk>
+
+.if defined(WITH_EXECUTABLE)
+CONFIGURE_ARGS+= --flags="executable"
+USE_CABAL+= cmdargs cprng-aes>=0.2.3 network
+EXECUTABLE+= stunnel checkciphers retrievecertificate simpleclient
+.else
+CONFIGURE_ARGS+= --flags="-executable"
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-tls/distinfo b/security/hs-tls/distinfo
new file mode 100644
index 00000000000..4ad84fb8bfa
--- /dev/null
+++ b/security/hs-tls/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/tls-0.8.5.tar.gz) = a9aa8a6410b99bf3a8dd26bfc0bbd65918394bafb3e388a96339a8e46d40bf1f
+SIZE (cabal/tls-0.8.5.tar.gz) = 32079
diff --git a/security/hs-tls/pkg-descr b/security/hs-tls/pkg-descr
new file mode 100644
index 00000000000..acdf7dfc342
--- /dev/null
+++ b/security/hs-tls/pkg-descr
@@ -0,0 +1,12 @@
+Native Haskell TLS and SSL protocol implementation for server and
+client.
+
+This provides a high-level implementation of a sensitive security
+protocol, eliminating a common set of security issues through the use of
+the advanced type system, high level constructions and common Haskell
+features.
+
+Currently implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, with
+only RSA supported for Key Exchange.
+
+WWW: http://github.com/vincenthz/hs-tls