aboutsummaryrefslogtreecommitdiffstats
path: root/security/libprelude/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2005-10-15 02:17:00 +0800
committersergei <sergei@FreeBSD.org>2005-10-15 02:17:00 +0800
commit153447b678a6764f058d3857948507f3554c32f5 (patch)
treed075e99b7ef3353da26f8b8d72bbc87c700d7d88 /security/libprelude/Makefile
parentc607ca81ab5c6eddf3941999d5dc83711f97116d (diff)
downloadfreebsd-ports-graphics-153447b678a6764f058d3857948507f3554c32f5.tar.gz
freebsd-ports-graphics-153447b678a6764f058d3857948507f3554c32f5.tar.zst
freebsd-ports-graphics-153447b678a6764f058d3857948507f3554c32f5.zip
- Respect NOPORTDOCS
- Fix pkg-plist if WITH_PERL/WITH_PYTHON are defined - Properly clean up (extra directories) at deinstall - Bump PORTREVISION
Diffstat (limited to 'security/libprelude/Makefile')
-rw-r--r--security/libprelude/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index 3d3f522292f..3af7d1f6c86 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -4,12 +4,13 @@
# $FreeBSD$
PORTNAME= libprelude
-DISTVERSION= 0.9.0
+PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.org/download/releases/
MAINTAINER= sergei@FreeBSD.org
-COMMENT= Prelude Network Intrusion Detection System librairies
+COMMENT= Framework library for Prelude NIDS
LIB_DEPENDS= gnutls.12:${PORTSDIR}/security/gnutls
@@ -17,10 +18,10 @@ USE_GPG= yes
SIG_SUFFIX= .sig
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc --localstatedir=/var
+CONFIGURE_ARGS= --localstatedir=/var
.if defined(WITH_PERL)
USE_PERL5= yes
@@ -40,8 +41,12 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-#.if defined(NOPORTDOCS)
-#MAKE_ENV+= NOPORTDOCS=yes
-#.endif
+.if !defined(NOPORTDOCS)
+CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}
+.endif
.include <bsd.port.mk>