aboutsummaryrefslogtreecommitdiffstats
path: root/security/metasploit
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-01-15 02:25:24 +0800
committerrm <rm@FreeBSD.org>2012-01-15 02:25:24 +0800
commit8a578193b19b7f1781e5f04d9158575bce2e43fd (patch)
tree2dc1f23aeb2c69dfc8d5fcb3ffd2c1f9e00664e7 /security/metasploit
parent6fa58306d12782ca047ea87afede801983f5274e (diff)
downloadfreebsd-ports-graphics-8a578193b19b7f1781e5f04d9158575bce2e43fd.tar.gz
freebsd-ports-graphics-8a578193b19b7f1781e5f04d9158575bce2e43fd.tar.zst
freebsd-ports-graphics-8a578193b19b7f1781e5f04d9158575bce2e43fd.zip
- fix runtime with ruby18 (add dependency on converters/ruby-iconv)
- drop option SVN_FBSD, because there is no more subversion-freebsd - bump portrevision because of dependency changes PR: 163831 Submitted by: Guilherme Oliveira <guilherme.oliveira at gmail dot com> Approved by: maintainer
Diffstat (limited to 'security/metasploit')
-rw-r--r--security/metasploit/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index c2fd40ccb63..04e662c8042 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= metasploit
DISTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://downloads.metasploit.com/data/releases/
DISTNAME= framework-${DISTVERSION}
@@ -21,11 +22,11 @@ WRKSRC= ${WRKDIR}/msf3
SCRIPTS= msfcli msfconsole msfd msfelfscan msfencode msfmachscan \
msfopcode msfpayload msfpescan msfweb
-OPTIONS= SVN "Use subversion" off \
- SVN_FBSD "Use subversion-freebsd" off
+OPTIONS= SVN "Use subversion" off
NO_BUILD= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= iconv
USE_BZIP2= yes
USE_NCURSES= yes
WITH_NCURSES_PORT= yes
@@ -38,17 +39,12 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/gem:${PORTSDIR}/devel/ruby-gems
RUN_DEPENDS+= rubygem-actionpack>0:${PORTSDIR}/www/rubygem-actionpack \
rubygem-sqlite3>0:${PORTSDIR}/databases/rubygem-sqlite3 \
rubygem-activerecord>0:${PORTSDIR}/databases/rubygem-activerecord \
- rubygem-activesupport>0:${PORTSDIR}/devel/rubygem-activesupport \
- ${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv
+ rubygem-activesupport>0:${PORTSDIR}/devel/rubygem-activesupport
.endif
-.if defined(WITH_SVN) || defined(WITH_SVN_FBSD)
-.if defined(WITH_SVN_FBSD)
-RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion-freebsd
-.else
+.if defined(WITH_SVN)
RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
.endif
-.endif
do-install:
${MKDIR} ${DATADIR}