aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>1999-11-12 04:49:44 +0800
committergreen <green@FreeBSD.org>1999-11-12 04:49:44 +0800
commit4c8c36a8ea2f840dbc249a02629d3f68330f04ba (patch)
tree4562f6f7602f1817342a622d20f4fe05281a4c2f /security/openssh
parenta0a44fe529655323c3eb15a1d660d4b4dedb05e5 (diff)
downloadfreebsd-ports-graphics-4c8c36a8ea2f840dbc249a02629d3f68330f04ba.tar.gz
freebsd-ports-graphics-4c8c36a8ea2f840dbc249a02629d3f68330f04ba.tar.zst
freebsd-ports-graphics-4c8c36a8ea2f840dbc249a02629d3f68330f04ba.zip
Correct the do-fetch target and improve error detection in fetchit.
Diffstat (limited to 'security/openssh')
-rw-r--r--security/openssh/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 86a53625f9b..46164016062 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -30,10 +30,10 @@ NO_CHECKSUM= YES
WRKSRC= ${WRKDIR}/ssh
do-fetch:
-.if !exists(${WRKDIR}/.fetch_done)
- @${SETENV} WRKDIR=${WRKDIR} ${SCRIPTDIR}/fetchit
-.endif
- @${TOUCH} ${WRKDIR}/.fetch_done
+ @if [ ! -e ${WRKDIR}/.fetch_done ]; then \
+ ${SETENV} WRKDIR=${WRKDIR} ${SCRIPTDIR}/fetchit || exit 1; \
+ ${TOUCH} ${WRKDIR}/.fetch_done; \
+ fi
do-extract:
@${CP} ${FILESDIR}/strlcpy.c ${WRKSRC}/lib/