aboutsummaryrefslogtreecommitdiffstats
path: root/security/pam-pgsql
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-01-09 03:17:27 +0800
committermi <mi@FreeBSD.org>2002-01-09 03:17:27 +0800
commit26e871adb0631a164d654dd65269c539d8947a13 (patch)
tree067f9e079dd3714900f0fe20ea65c204a1b4c943 /security/pam-pgsql
parent48346b789d645c1f2058dd256ca7e4c006c8543f (diff)
downloadfreebsd-ports-graphics-26e871adb0631a164d654dd65269c539d8947a13.tar.gz
freebsd-ports-graphics-26e871adb0631a164d654dd65269c539d8947a13.tar.zst
freebsd-ports-graphics-26e871adb0631a164d654dd65269c539d8947a13.zip
Upgrade to 0.5.1. It now uses mhash, BTW.
Submitted by: fenner's script (thanks!)
Diffstat (limited to 'security/pam-pgsql')
-rw-r--r--security/pam-pgsql/Makefile6
-rw-r--r--security/pam-pgsql/distinfo2
-rw-r--r--security/pam-pgsql/files/Makefile.bsd7
3 files changed, 8 insertions, 7 deletions
diff --git a/security/pam-pgsql/Makefile b/security/pam-pgsql/Makefile
index 1a82061a783..b3a40e9b347 100644
--- a/security/pam-pgsql/Makefile
+++ b/security/pam-pgsql/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pam-pgsql
-PORTVERSION= 0.3
-PORTREVISION= 1
+PORTVERSION= 0.5.1
CATEGORIES= security databases
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/p/pam-pgsql
@@ -15,7 +14,8 @@ DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= mi@aldan.algebra.com
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= mhash:${PORTSDIR}/security/mhash \
+ pq:${PORTSDIR}/databases/postgresql7
# When the family of Debian mirrors is added to bsd.port.mk,
# this will suddenly start making sense:
diff --git a/security/pam-pgsql/distinfo b/security/pam-pgsql/distinfo
index abe6bbb45e4..67ce617226b 100644
--- a/security/pam-pgsql/distinfo
+++ b/security/pam-pgsql/distinfo
@@ -1 +1 @@
-MD5 (pam-pgsql_0.3.tar.gz) = c34c18f98690e579da7cf810a3db2a00
+MD5 (pam-pgsql_0.5.1.tar.gz) = f4c550f10d049e585612bb65386c6140
diff --git a/security/pam-pgsql/files/Makefile.bsd b/security/pam-pgsql/files/Makefile.bsd
index 43e689a0de9..9d000dc4ef2 100644
--- a/security/pam-pgsql/files/Makefile.bsd
+++ b/security/pam-pgsql/files/Makefile.bsd
@@ -4,11 +4,12 @@ SRCS= pam_pgsql.c pam_get_pass.c pam_std_option.c pam_get_service.c
LIB= pam_pgsql
SHLIB_NAME=${LIB}.so
-LDADD= -lpam -L${LOCALBASE}/lib -lpq
-INCLUDE= -I${LOCALBASE}/include/pgsql
-CFLAGS+= -Wall -D_GNU_SOURCE -I${LOCALBASE}/include/pgsql
+LDADD= -lpam -L${LOCALBASE}/lib -lpq -lmhash
+CFLAGS+= -Wall -D_GNU_SOURCE \
+ -I${LOCALBASE}/include/pgsql -I${LOCALBASE}/include
INTERNALLIB= we don't need no stinking static lib
+NOPROFILE= we don't need no profiling either
# Uncomment if you think, the lib should NOT go into /usr/lib directly:
# LIBDIR= ${LOCALBASE}/lib