aboutsummaryrefslogtreecommitdiffstats
path: root/security/pam_krb5/Makefile
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2001-07-25 01:14:44 +0800
committernectar <nectar@FreeBSD.org>2001-07-25 01:14:44 +0800
commit8979bbf81e94439b8d390216f4c20aa9b044fb3d (patch)
treebc2401f9f19316939d72f722ab43460021d1810c /security/pam_krb5/Makefile
parent5211c8b3277fb41ed6af819b3dbab648d24d4d97 (diff)
downloadfreebsd-ports-graphics-8979bbf81e94439b8d390216f4c20aa9b044fb3d.tar.gz
freebsd-ports-graphics-8979bbf81e94439b8d390216f4c20aa9b044fb3d.tar.zst
freebsd-ports-graphics-8979bbf81e94439b8d390216f4c20aa9b044fb3d.zip
Update pam_krb5 1.0 -> 1.0.1.
Change MASTER_SITES. NB: This versioning is bogus. Unfortunately, there is no official release of pam_krb5 yet, but it has substantially changed. I made this release based on what is in CVS.
Diffstat (limited to 'security/pam_krb5/Makefile')
-rw-r--r--security/pam_krb5/Makefile77
1 files changed, 38 insertions, 39 deletions
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index 8ca177815d8..5493d8138bf 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -6,51 +6,50 @@
#
PORTNAME= pam_krb5
-PORTVERSION= 1.0
-PORTREVISION= 2
+PORTVERSION= 1.0.1
CATEGORIES= security
-MASTER_SITES= http://www.fcusack.com/soft/
+MASTER_SITES= http://www.nectar.com/distfiles/
MAINTAINER= nectar@FreeBSD.org
-WRKSRC= ${WRKDIR}/pam_krb5
-PREFIX?= ${DESTDIR}/usr
-MANPREFIX?= ${DESTDIR}/usr/share
-MAKE_ENV= PREFIX="${PREFIX}" MANPREFIX="${MANPREFIX}" \
- KRB5BASE="${KRB5BASE}" KRB5_IMPL="${KRB5_IMPL}"
-
MAN8= pam_krb5.8
-.include <bsd.port.pre.mk>
-
-# Try hard to figure out which Kerberos implementation we should use to
-# build this thing. There are three possibilities:
-# Heimdal in the base system -- XXX disabled for now (missing libraries)
-# Heimdal from ports
-# MIT Kerberos from ports
-.if defined(KRB5BASE) && defined(KRB5_IMPL)
-# the user thinks he knows what he is doing, so let it be
-.elif exists(/usr/include/heim_err.h) && defined(REALLY_WANT_BASE) && (${REALLY_WANT_BASE} == "yes")
-KRB5BASE=/usr
-KRB5_IMPL="heimdal"
-.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/include/heim_err.h)
-KRB5BASE=${HEIMDAL_HOME}
-KRB5_IMPL=heimdal
-LIB_DEPENDS+= krb5.16:${PORTSDIR}/security/heimdal
-.elif exists(${LOCALBASE}/include/heim_err.h)
-KRB5BASE=${LOCALBASE}
-KRB5_IMPL=heimdal
-LIB_DEPENDS+= krb5.16:${PORTSDIR}/security/heimdal
-.elif defined(KRB5_HOME) && exists(${KRB5_HOME}/include/mit-sipb-copyright.h)
-KRB5BASE=${KRB5_HOME}
-KRB5_IMPL=mit
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
-.elif exists(${LOCALBASE}/include/mit-sipb-copyright.h)
-KRB5BASE=${LOCALBASE}
-KRB5_IMPL=mit
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+.if defined(PACKAGE_BUILDING)
+KRB5_IMPL= heimdal
+.endif
+
+.if defined(KRB5_IMPL) && ${KRB5_IMPL} == heimdal
+LIB_DEPENDS= krb5.18:${PORTSDIR}/security/heimdal
+.if defined(HEIMDAL_HOME)
+KRB5_DIR?= ${HEIMDAL_HOME}
+.endif
+.elif defined(KRB5_IMPL) && ${KRB5_IMPL} == mit
+LIB_DEPENDS= krb5.3:${PORTSDIR}/security/krb5
+.if defined(KRB5_HOME)
+KRB5_DIR?= ${KRB5_HOME}
+.endif
+.else
+BROKEN= You must define KRB5_IMPL to be \"mit\" or \"heimdal\"
+.endif
+
+.if defined(PREFIX)
+MANDIR= ${PREFIX}/man
.else
-BROKEN= "No version of Kerberos is installed."
+PREFIX= ${DESTDIR}/usr
+MANPREFIX= ${DESTDIR}/usr/share
+MANDIR= ${PREFIX}/share/man
.endif
+KRB5_DIR?= ${LOCALBASE}
+CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}" \
+ --with-pamdir="${PREFIX}/lib" \
+ --with-man-sect=8 \
+ --mandir=${MANDIR}
+
+post-install:
+ cd ${WRKSRC} && ${MAKE} install-man
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>