aboutsummaryrefslogtreecommitdiffstats
path: root/security/pear-Auth_OpenID
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2008-03-04 18:43:08 +0800
committermm <mm@FreeBSD.org>2008-03-04 18:43:08 +0800
commit8f317d31a5cde42d059a0bf725f45a4e481d6616 (patch)
treeda0cc65cb574e37e8a3cc598877f4cc5f3db7ac2 /security/pear-Auth_OpenID
parent4b355e23c2753d7f7b9f36f7d2e26e857caafa9c (diff)
downloadfreebsd-ports-graphics-8f317d31a5cde42d059a0bf725f45a4e481d6616.tar.gz
freebsd-ports-graphics-8f317d31a5cde42d059a0bf725f45a4e481d6616.tar.zst
freebsd-ports-graphics-8f317d31a5cde42d059a0bf725f45a4e481d6616.zip
This is version 2 of PHP OpenID using the PEAR framework.
The PHP OpenID library lets you enable OpenID authentication on sites built using PHP. It features the OpenID consumer, Store implementations, and an OpenID server. WWW: http://openidenabled.com/php-openid/
Diffstat (limited to 'security/pear-Auth_OpenID')
-rw-r--r--security/pear-Auth_OpenID/Makefile183
-rw-r--r--security/pear-Auth_OpenID/distinfo3
-rw-r--r--security/pear-Auth_OpenID/files/patch-admin-package2.xml11
-rw-r--r--security/pear-Auth_OpenID/files/patch-admin-xmlconfig.py11
-rw-r--r--security/pear-Auth_OpenID/pkg-descr5
5 files changed, 213 insertions, 0 deletions
diff --git a/security/pear-Auth_OpenID/Makefile b/security/pear-Auth_OpenID/Makefile
new file mode 100644
index 00000000000..84dbb4d7126
--- /dev/null
+++ b/security/pear-Auth_OpenID/Makefile
@@ -0,0 +1,183 @@
+# New ports collection makefile for: php-openid
+# Date created: 2008-03-03
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Auth_OpenID
+PORTVERSION= 2.0.1
+CATEGORIES= security www pear
+MASTER_SITES= http://openidenabled.com/files/php-openid/packages/
+DISTNAME= php-openid-${PORTVERSION}
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= PHP OpenID library v2 for PEAR
+
+RUN_DEPENDS= pear:${PORTSDIR}/devel/pear
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+CONFLICTS= php-Auth_OpenID-1.*
+
+USE_BZIP2= yes
+LATEST_LINK= pear-Auth_OpenID
+
+WRKSRC= ${WRKDIR}/php-openid-${PORTVERSION}
+
+OPTIONS= BCMATH "Use bcmath instead of libgmp" off
+
+USE_PHP= curl dom
+USE_PYTHON_BUILD= yes
+
+FILES= Auth/OpenID.php Auth/OpenID/AX.php \
+ Auth/OpenID/Association.php Auth/OpenID/BigMath.php \
+ Auth/OpenID/Consumer.php Auth/OpenID/CryptUtil.php \
+ Auth/OpenID/DatabaseConnection.php \
+ Auth/OpenID/DiffieHellman.php Auth/OpenID/Discover.php \
+ Auth/OpenID/DumbStore.php Auth/OpenID/Extension.php \
+ Auth/OpenID/FileStore.php Auth/OpenID/HMACSHA1.php \
+ Auth/OpenID/Interface.php Auth/OpenID/KVForm.php \
+ Auth/OpenID/Message.php Auth/OpenID/MySQLStore.php \
+ Auth/OpenID/Nonce.php Auth/OpenID/PAPE.php \
+ Auth/OpenID/Parse.php Auth/OpenID/PostgreSQLStore.php \
+ Auth/OpenID/SQLStore.php Auth/OpenID/SQLiteStore.php \
+ Auth/OpenID/SReg.php Auth/OpenID/Server.php \
+ Auth/OpenID/ServerRequest.php Auth/OpenID/TrustRoot.php \
+ Auth/OpenID/URINorm.php \
+ Auth/Yadis/HTTPFetcher.php Auth/Yadis/Manager.php \
+ Auth/Yadis/Misc.php Auth/Yadis/ParanoidHTTPFetcher.php \
+ Auth/Yadis/ParseHTML.php Auth/Yadis/PlainHTTPFetcher.php \
+ Auth/Yadis/XML.php Auth/Yadis/XRDS.php Auth/Yadis/XRI.php \
+ Auth/Yadis/XRIRes.php Auth/Yadis/Yadis.php
+
+DOCS= OpenID/Auth_OpenID_AX.html \
+ OpenID/Auth_OpenID_AX_AttrInfo.html \
+ OpenID/Auth_OpenID_AX_Error.html \
+ OpenID/Auth_OpenID_AX_FetchRequest.html \
+ OpenID/Auth_OpenID_AX_FetchResponse.html \
+ OpenID/Auth_OpenID_AX_KeyValueMessage.html \
+ OpenID/Auth_OpenID_AX_Message.html \
+ OpenID/Auth_OpenID_AX_StoreRequest.html \
+ OpenID/Auth_OpenID_AX_StoreResponse.html \
+ OpenID/Auth_OpenID_AlreadySigned.html \
+ OpenID/Auth_OpenID_AssociateRequest.html \
+ OpenID/Auth_OpenID_Association.html \
+ OpenID/Auth_OpenID_AuthRequest.html \
+ OpenID/Auth_OpenID_CancelResponse.html \
+ OpenID/Auth_OpenID_CheckAuthRequest.html \
+ OpenID/Auth_OpenID_CheckIDRequest.html \
+ OpenID/Auth_OpenID_Consumer.html \
+ OpenID/Auth_OpenID_ConsumerResponse.html \
+ OpenID/Auth_OpenID_DatabaseConnection.html \
+ OpenID/Auth_OpenID_Decoder.html \
+ OpenID/Auth_OpenID_DiffieHellmanSHA1ConsumerSession.html \
+ OpenID/Auth_OpenID_DiffieHellmanSHA1ServerSession.html \
+ OpenID/Auth_OpenID_DiffieHellmanSHA256ConsumerSession.html \
+ OpenID/Auth_OpenID_DiffieHellmanSHA256ServerSession.html \
+ OpenID/Auth_OpenID_DumbStore.html \
+ OpenID/Auth_OpenID_Encoder.html \
+ OpenID/Auth_OpenID_EncodingError.html \
+ OpenID/Auth_OpenID_Extension.html \
+ OpenID/Auth_OpenID_FailureResponse.html \
+ OpenID/Auth_OpenID_FileStore.html \
+ OpenID/Auth_OpenID_GenericConsumer.html \
+ OpenID/Auth_OpenID_MalformedReturnURL.html \
+ OpenID/Auth_OpenID_MalformedTrustRoot.html \
+ OpenID/Auth_OpenID_Mapping.html \
+ OpenID/Auth_OpenID_Message.html \
+ OpenID/Auth_OpenID_MySQLStore.html \
+ OpenID/Auth_OpenID_NamespaceMap.html \
+ OpenID/Auth_OpenID_NoReturnToError.html \
+ OpenID/Auth_OpenID_OpenIDStore.html \
+ OpenID/Auth_OpenID_PAPE_Request.html \
+ OpenID/Auth_OpenID_PAPE_Response.html \
+ OpenID/Auth_OpenID_PlainTextConsumerSession.html \
+ OpenID/Auth_OpenID_PlainTextServerSession.html \
+ OpenID/Auth_OpenID_PostgreSQLStore.html \
+ OpenID/Auth_OpenID_Request.html \
+ OpenID/Auth_OpenID_SQLStore.html \
+ OpenID/Auth_OpenID_SQLiteStore.html \
+ OpenID/Auth_OpenID_SRegBase.html \
+ OpenID/Auth_OpenID_SRegRequest.html \
+ OpenID/Auth_OpenID_SRegResponse.html \
+ OpenID/Auth_OpenID_Server.html \
+ OpenID/Auth_OpenID_ServerError.html \
+ OpenID/Auth_OpenID_ServerErrorContainer.html \
+ OpenID/Auth_OpenID_ServerRequest.html \
+ OpenID/Auth_OpenID_ServerResponse.html \
+ OpenID/Auth_OpenID_ServiceEndpointLoader.html \
+ OpenID/Auth_OpenID_SessionNegotiator.html \
+ OpenID/Auth_OpenID_SetupNeededResponse.html \
+ OpenID/Auth_OpenID_Signatory.html \
+ OpenID/Auth_OpenID_SigningEncoder.html \
+ OpenID/Auth_OpenID_SuccessResponse.html \
+ OpenID/Auth_OpenID_TypeURIMismatch.html \
+ OpenID/Auth_OpenID_UntrustedReturnURL.html \
+ OpenID/Auth_OpenID_WebResponse.html \
+ OpenID/Auth_Yadis_Discovery.html \
+ OpenID/Auth_Yadis_DiscoveryResult.html \
+ OpenID/Auth_Yadis_Manager.html \
+ OpenID/Auth_Yadis_ManagerLoader.html \
+ OpenID/Auth_Yadis_PHPSession.html \
+ OpenID/Auth_Yadis_Service.html \
+ OpenID/Auth_Yadis_SessionLoader.html \
+ OpenID/Auth_Yadis_XMLParser.html \
+ OpenID/Auth_Yadis_XRDS.html \
+ OpenID/Auth_Yadis_Yadis.html \
+ OpenID/Auth_Yadis_dom.html \
+ OpenID/Auth_Yadis_domxml.html \
+ OpenID/_Auth---OpenID---AX.php.html \
+ OpenID/_Auth---OpenID---Association.php.html \
+ OpenID/_Auth---OpenID---Consumer.php.html \
+ OpenID/_Auth---OpenID---DatabaseConnection.php.html \
+ OpenID/_Auth---OpenID---DumbStore.php.html \
+ OpenID/_Auth---OpenID---Extension.php.html \
+ OpenID/_Auth---OpenID---FileStore.php.html \
+ OpenID/_Auth---OpenID---Interface.php.html \
+ OpenID/_Auth---OpenID---Message.php.html \
+ OpenID/_Auth---OpenID---MySQLStore.php.html \
+ OpenID/_Auth---OpenID---Nonce.php.html \
+ OpenID/_Auth---OpenID---PAPE.php.html \
+ OpenID/_Auth---OpenID---PostgreSQLStore.php.html \
+ OpenID/_Auth---OpenID---SQLStore.php.html \
+ OpenID/_Auth---OpenID---SQLiteStore.php.html \
+ OpenID/_Auth---OpenID---SReg.php.html \
+ OpenID/_Auth---OpenID---Server.php.html \
+ OpenID/_Auth---OpenID---ServerRequest.php.html \
+ OpenID/_Auth---OpenID.php.html \
+ OpenID/_Auth---Yadis---Manager.php.html \
+ OpenID/_Auth---Yadis---XML.php.html \
+ OpenID/_Auth---Yadis---XRDS.php.html \
+ OpenID/_Auth---Yadis---Yadis.php.html \
+ OpenID/tutorial_OpenID.pkg.html \
+ classtrees_OpenID.html elementindex.html \
+ elementindex_OpenID.html errors.html index.html \
+ li_OpenID.html packages.html \
+ media/banner.css media/stylesheet.css
+
+EXAMPLES= README consumer/common.php consumer/finish_auth.php \
+ consumer/index.php consumer/try_auth.php \
+ detect.php server/index.php server/lib/actions.php \
+ server/lib/common.php server/lib/render.php \
+ server/lib/render/about.php server/lib/render/idpXrds.php \
+ server/lib/render/idpage.php server/lib/render/login.php \
+ server/lib/render/trust.php server/lib/render/userXrds.php \
+ server/lib/session.php server/openid-server.css \
+ server/server.php server/setup.php
+
+_DOCSDIR= doc
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+EXTRACT_SUFX= .tar.bz2
+
+.ifdef(WITH_BCMATH)
+USE_PHP+= bcmath
+.else
+USE_PHP+= gmp
+.endif
+
+post-configure:
+ @cd ${WRKSRC}/admin && ${PYTHON_CMD} packagexml.py ${PORTVERSION} package2.xml ../CHANGELOG > ${WRKDIR}/package.xml
+
+.include <bsd.port.post.mk>
diff --git a/security/pear-Auth_OpenID/distinfo b/security/pear-Auth_OpenID/distinfo
new file mode 100644
index 00000000000..325ba46a85e
--- /dev/null
+++ b/security/pear-Auth_OpenID/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/php-openid-2.0.1.tar.bz2) = e8be2d48139b4faa45626661c329bdb2
+SHA256 (PEAR/php-openid-2.0.1.tar.bz2) = db73c30924067c8388662f734a814e8c7256681906e69658d98fb118ef2aa241
+SIZE (PEAR/php-openid-2.0.1.tar.bz2) = 298646
diff --git a/security/pear-Auth_OpenID/files/patch-admin-package2.xml b/security/pear-Auth_OpenID/files/patch-admin-package2.xml
new file mode 100644
index 00000000000..e8d9a287477
--- /dev/null
+++ b/security/pear-Auth_OpenID/files/patch-admin-package2.xml
@@ -0,0 +1,11 @@
+--- admin/package2.xml.orig 2008-03-03 16:32:47.455788708 +0100
++++ admin/package2.xml 2008-03-03 16:33:01.007309698 +0100
+@@ -7,7 +7,7 @@
+ http://pear.php.net/dtd/package-2.0
+ http://pear.php.net/dtd/package-2.0.xsd">
+ <name>%(package_name)s</name>
+- <uri>%(uri)s</uri>
++ <channel>pear.php.net</channel>
+ <summary>%(package_summary)s</summary>
+ <description>
+ %(package_description)s
diff --git a/security/pear-Auth_OpenID/files/patch-admin-xmlconfig.py b/security/pear-Auth_OpenID/files/patch-admin-xmlconfig.py
new file mode 100644
index 00000000000..3aed51f9158
--- /dev/null
+++ b/security/pear-Auth_OpenID/files/patch-admin-xmlconfig.py
@@ -0,0 +1,11 @@
+--- admin/xmlconfig.py.orig 2008-02-20 23:13:48.000000000 +0100
++++ admin/xmlconfig.py 2008-03-03 16:39:09.376694098 +0100
+@@ -48,7 +48,7 @@
+ # The HTTP package base URI. This is the place on the web where the
+ # PEAR-installable tarballs will live, and this (plus the package
+ # tarball name) will be the URL that users pass to "pear install".
+-package_base_uri = 'http://www.openidenabled.com/resources/downloads/php-openid/pear/'
++package_base_uri = 'http://openidenabled.com/files/php-openid/packages/'
+
+ # The release stability. Maybe this should be a commandline parameter
+ # since it might differ from release to release.
diff --git a/security/pear-Auth_OpenID/pkg-descr b/security/pear-Auth_OpenID/pkg-descr
new file mode 100644
index 00000000000..d5ea3a68ff9
--- /dev/null
+++ b/security/pear-Auth_OpenID/pkg-descr
@@ -0,0 +1,5 @@
+The PHP OpenID library lets you enable OpenID authentication on sites built
+using PHP. It features the OpenID consumer, Store implementations, and an
+OpenID server.
+
+WWW: http://openidenabled.com/php-openid/