aboutsummaryrefslogtreecommitdiffstats
path: root/security/php4-cryptopp
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-30 21:07:02 +0800
committerpav <pav@FreeBSD.org>2005-01-30 21:07:02 +0800
commita570ad0f2383a4e71f5fb08d2bd4e429b483b478 (patch)
tree16b9de731eeeb4d8a8be336ea43a85d2c42b1ed8 /security/php4-cryptopp
parentc7fd624e00a75a693fa7d435fa92f7fe3d177a78 (diff)
downloadfreebsd-ports-graphics-a570ad0f2383a4e71f5fb08d2bd4e429b483b478.tar.gz
freebsd-ports-graphics-a570ad0f2383a4e71f5fb08d2bd4e429b483b478.tar.zst
freebsd-ports-graphics-a570ad0f2383a4e71f5fb08d2bd4e429b483b478.zip
cryptopp-php is a cryptography extension for PHP based on Wei Dai's
Crypto++, a free C++ crypto library. PR: ports/76810 Submitted by: Thomas Melzer <tmelzer@tomesoft.de>
Diffstat (limited to 'security/php4-cryptopp')
-rw-r--r--security/php4-cryptopp/Makefile48
-rw-r--r--security/php4-cryptopp/distinfo2
-rw-r--r--security/php4-cryptopp/pkg-descr4
3 files changed, 54 insertions, 0 deletions
diff --git a/security/php4-cryptopp/Makefile b/security/php4-cryptopp/Makefile
new file mode 100644
index 00000000000..046d707905e
--- /dev/null
+++ b/security/php4-cryptopp/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: php4-cryptopp
+# Date created: 28 Jan 2004
+# Whom: tmelzer
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptopp
+PORTVERSION= 0.0.15
+CATEGORIES= security
+MASTER_SITES= http://bugs.tutorbuddy.com/download.php/
+PKGNAMEPREFIX= php4-
+DISTNAME= ${PORTNAME}-php-${PORTVERSION}
+
+MAINTAINER= tmelzer@tomesoft.de
+COMMENT= A crypto++ php wrapper
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAME}
+
+USE_PERL= yes
+USE_PHP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_ARGS= --with-cryptopp
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README ${PORTNAME}.doc
+.endif
+
+post-extract:
+# convert sgml documentation to plain text
+ @${PERL} -e '$$/=">";' -e 'while(<>){s/<.*>//;print;}' < ${WRKSRC}/docs/${PORTNAME}.sgml > ${WRKSRC}/${PORTNAME}.doc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-march=pentium3 -O3 -g -pipe -fomit-frame-pointer|${CFLAGS}|' ${WRKSRC}/config.m4
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/php4-cryptopp/distinfo b/security/php4-cryptopp/distinfo
new file mode 100644
index 00000000000..08e5fde1fa9
--- /dev/null
+++ b/security/php4-cryptopp/distinfo
@@ -0,0 +1,2 @@
+MD5 (cryptopp-php-0.0.15.tar.gz) = b94f01400bffb8f2926d8fb2f986df60
+SIZE (cryptopp-php-0.0.15.tar.gz) = 115690
diff --git a/security/php4-cryptopp/pkg-descr b/security/php4-cryptopp/pkg-descr
new file mode 100644
index 00000000000..2cbd0a3ad79
--- /dev/null
+++ b/security/php4-cryptopp/pkg-descr
@@ -0,0 +1,4 @@
+cryptopp-php is a cryptography extension for PHP based on Wei Dai's
+Crypto++, a free C++ crypto library.
+
+WWW: http://bugs.tutorbuddy.com/