aboutsummaryrefslogtreecommitdiffstats
path: root/security/racoon2/Makefile
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2005-02-02 02:59:09 +0800
committersumikawa <sumikawa@FreeBSD.org>2005-02-02 02:59:09 +0800
commit58ee460ec1e5de087b74382e1f795a1adf2fcc5d (patch)
tree8c8d9d1b0986e74b16b60c4f723ea9c675a64751 /security/racoon2/Makefile
parenta71f0577f08e7e6436b8e23f3386459333f0ebd3 (diff)
downloadfreebsd-ports-graphics-58ee460ec1e5de087b74382e1f795a1adf2fcc5d.tar.gz
freebsd-ports-graphics-58ee460ec1e5de087b74382e1f795a1adf2fcc5d.tar.zst
freebsd-ports-graphics-58ee460ec1e5de087b74382e1f795a1adf2fcc5d.zip
"racoon2" is a system to exchange and to install security parameters
for the IPsec. Currently the system supports the following specification: Internet Key Exchange (IKEv2) Protocol draft-ietf-ipsec-ikev2-17.txt (The IKE daemon is not included in the current release due to IPR issue) Kerberized Internet Negotiation of Keys (KINK) draft-ietf-kink-kink-06.txt PF_KEY Key Management API, Version 2 RFC2367 The following protocols will be supported soon. The Internet Key Exchange (IKE) RFC2409 WWW: http://www.kame.net/ This port was repocopied from secutiry/racoon. PR: ports/76814
Diffstat (limited to 'security/racoon2/Makefile')
-rw-r--r--security/racoon2/Makefile62
1 files changed, 33 insertions, 29 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index a68efae0f18..feffbb4a143 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -1,51 +1,55 @@
-# New ports collection makefile for: racoon
-# Date created: 4 July 2000
+# New ports collection makefile for: racoon2
+# Date created: 4 Feb 2005
# Whom: sumikawa
#
# $FreeBSD$
#
-PORTNAME= racoon
-PORTVERSION= 20040818a
-PORTREVISION= 1
+PORTNAME= racoon2
+PORTVERSION= 20050128b
CATEGORIES= security net ipv6
-MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
+MASTER_SITES= ftp://ftp.kame.net/pub/racoon2/
+EXTRACT_SUFX= .tgz
MAINTAINER= sumikawa@FreeBSD.org
-COMMENT= KAME racoon IKE daemon
-
-.if !exists(/usr/lib/libipsec.so.1) && !exists(/lib/libipsec.so.1)
-BROKEN= "You must upgrade the OS"
-.endif
+COMMENT= Racoon2 IPsec daemon
USE_RC_SUBR= YES
USE_OPENSSL= YES
-WRKSRC= ${WRKDIR}/${DISTNAME}/racoon
+USE_AUTOCONF_VER=259
+CONFIGURE_TARGET=
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include CFLAGS=-I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -L${WRKSRC}/../libipsec
-CONFIGURE_ARGS+=--enable-debug
-CONFIGURE_ARGS+=--enable-ipv6
CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
-CONFIGURE_ARGS+=--with-pkgversion=freebsd-${PORTVERSION}
-
-MAN5= racoon.conf.5
-MAN8= racoon.8
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
- RC_SUBR=${RC_SUBR}
+.if !defined(NOPORTDOCS)
+PORTDOCS= INSTALL USAGE.iked USAGE.kinkd USAGE.spmd config-usage.ja.txt
+PORTDOCS+= draft-ietf-ipsec-ikev2-17.txt draft-ietf-kink-kink-06.txt
+PORTDOCS+= iked-memo.ja.txt kink-spec-supplement.ja.txt
+PORTDOCS+= kinkd-data-struct.obj kinkd-impl.ja.txt kinkd-install.ja.txt
+PORTDOCS+= kinkd-state-txn.obj libracoon.ja.txt specification.ja.txt
+PORTDOCS+= spmif.txt system-message.ja.txt
+.endif
pre-patch:
- ${MV} ${WRKSRC}/racoon.8 ${WRKSRC}/racoon.8.in
-
-pre-configure:
- (cd ${WRKSRC}/../libipsec; make)
+ (cd ${WRKSRC}/samples ;\
+ ${MV} racoon2.conf racoon2.conf.in ;\
+ ${MV} init.d-kinkd init.d-kinkd.in ;\
+ ${MV} init.d-spmd init.d-spmd.in ;\
+ ${MV} rc.d-kinkd rc.d-kinkd.in ;\
+ ${MV} rc.d-spmd rc.d-spmd.in )
post-install:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/racoon.sh > ${PREFIX}/etc/rc.d/racoon.sh
- @${CHMOD} +x ${PREFIX}/etc/rc.d/racoon.sh
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT.jp ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.iked ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+.endfor
+.endif
@if [ -z `/sbin/sysctl -a | ${GREP} -q ipsec && echo ipsec` ]; then \
${ECHO_MSG} "WARNING: IPsec feature is disabled on this host"; \
${ECHO_MSG} " You must build the kernel if you want to run racoon on the host"; \