aboutsummaryrefslogtreecommitdiffstats
path: root/security/rubygem-net-sftp
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /security/rubygem-net-sftp
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-graphics-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-graphics-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-graphics-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'security/rubygem-net-sftp')
-rw-r--r--security/rubygem-net-sftp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/rubygem-net-sftp/Makefile b/security/rubygem-net-sftp/Makefile
index b6a529ac989..e7c0b95f8f4 100644
--- a/security/rubygem-net-sftp/Makefile
+++ b/security/rubygem-net-sftp/Makefile
@@ -17,6 +17,7 @@ COMMENT= Implementation of the SFTP client protocol
RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/net-ssh-1.1.2.gemspec:${PORTSDIR}/security/rubygem-net-ssh
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>