aboutsummaryrefslogtreecommitdiffstats
path: root/security/rubygem-rc4
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-06-22 10:37:58 +0800
committerswills <swills@FreeBSD.org>2013-06-22 10:37:58 +0800
commitf369f2ea56f3501a5f882cecf4663213f9aad271 (patch)
tree697fd5a691da4726be08d911b51adacea6fea267 /security/rubygem-rc4
parent29b7c71f894dda7e4fff1cd565481a3658d3be43 (diff)
downloadfreebsd-ports-graphics-f369f2ea56f3501a5f882cecf4663213f9aad271.tar.gz
freebsd-ports-graphics-f369f2ea56f3501a5f882cecf4663213f9aad271.tar.zst
freebsd-ports-graphics-f369f2ea56f3501a5f882cecf4663213f9aad271.zip
A pure Ruby implementation of the RC4 algorithm
WWW: http://rubygems.org/gems/ruby-rc4
Diffstat (limited to 'security/rubygem-rc4')
-rw-r--r--security/rubygem-rc4/Makefile18
-rw-r--r--security/rubygem-rc4/distinfo2
-rw-r--r--security/rubygem-rc4/pkg-descr3
3 files changed, 23 insertions, 0 deletions
diff --git a/security/rubygem-rc4/Makefile b/security/rubygem-rc4/Makefile
new file mode 100644
index 00000000000..268a11d817e
--- /dev/null
+++ b/security/rubygem-rc4/Makefile
@@ -0,0 +1,18 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rc4
+PORTVERSION= 0.1.5
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Pure Ruby implementation of the RC4 algorithm
+
+GEM_NAME= ${DISTNAME}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-rc4/distinfo b/security/rubygem-rc4/distinfo
new file mode 100644
index 00000000000..963726ff7f8
--- /dev/null
+++ b/security/rubygem-rc4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-rc4-0.1.5.gem) = 00cc40a39d20b53f5459e7ea006a92cf584e9bc275e2a6f7aa1515510e896c03
+SIZE (rubygem/ruby-rc4-0.1.5.gem) = 7168
diff --git a/security/rubygem-rc4/pkg-descr b/security/rubygem-rc4/pkg-descr
new file mode 100644
index 00000000000..76d26bc365f
--- /dev/null
+++ b/security/rubygem-rc4/pkg-descr
@@ -0,0 +1,3 @@
+A pure Ruby implementation of the RC4 algorithm
+
+WWW: http://rubygems.org/gems/ruby-rc4