aboutsummaryrefslogtreecommitdiffstats
path: root/security/skip/files/patch-bc
diff options
context:
space:
mode:
authorarchie <archie@FreeBSD.org>1999-03-11 06:28:00 +0800
committerarchie <archie@FreeBSD.org>1999-03-11 06:28:00 +0800
commit7f99bff53bc65f085ef920dd82a1241a4a317499 (patch)
treefe9be052c2616d02a047f336a15bef7e08f36b41 /security/skip/files/patch-bc
parent5e25cf710d756f4f1253cf79a42a6ec8d9b2db31 (diff)
downloadfreebsd-ports-graphics-7f99bff53bc65f085ef920dd82a1241a4a317499.tar.gz
freebsd-ports-graphics-7f99bff53bc65f085ef920dd82a1241a4a317499.tar.zst
freebsd-ports-graphics-7f99bff53bc65f085ef920dd82a1241a4a317499.zip
Build SKIP port as a KLD instead of an LKM.
Diffstat (limited to 'security/skip/files/patch-bc')
-rw-r--r--security/skip/files/patch-bc83
1 files changed, 72 insertions, 11 deletions
diff --git a/security/skip/files/patch-bc b/security/skip/files/patch-bc
index 0177ad2efe2..1ecbfe8e44e 100644
--- a/security/skip/files/patch-bc
+++ b/security/skip/files/patch-bc
@@ -1,12 +1,73 @@
-diff -ur --unidirectional-new-file skipsrc-1.0.orig/skip/freebsd/Makefile.defs skipsrc-1.0/skip/freebsd/Makefile.defs
---- skipsrc-1.0.orig/skip/freebsd/Makefile.defs Fri Oct 25 13:12:42 1996
-+++ skipsrc-1.0/skip/freebsd/Makefile.defs Fri Nov 21 11:39:11 1997
-@@ -93,7 +93,7 @@
+diff -ur --unidirectional-new-file skipsrc-1.0.orig/skip/bdcmod/des_ecb/dessp.c work.new/skip/bdcmod/des_ecb/dessp.c
+--- skipsrc-1.0.orig/skip/bdcmod/des_ecb/dessp.c Fri Oct 25 13:12:34 1996
++++ work.new/skip/bdcmod/des_ecb/dessp.c Mon Mar 8 21:33:38 1999
+@@ -2,6 +2,7 @@
+ #pragma ident "@(#)dessp.c 1.2 95/11/15 Sun Microsystems"
- # Kernel compilation flags
- #
--K_FLAGS_FREEBSD_gnu = -DKERNEL -DFREEBSD
-+K_FLAGS_FREEBSD_gnu = -DKERNEL -DACTUALLY_LKM_NOT_KERNEL
-
- # OS Libraries
- #
+ unsigned long Spbox[8][64] = {
++{
+ 0x01010400,0x00000000,0x00010000,0x01010404,
+ 0x01010004,0x00010404,0x00000004,0x00010000,
+ 0x00000400,0x01010400,0x01010404,0x00000400,
+@@ -18,6 +19,7 @@
+ 0x01000004,0x00000404,0x00010404,0x01010400,
+ 0x00000404,0x01000400,0x01000400,0x00000000,
+ 0x00010004,0x00010400,0x00000000,0x01010004,
++}, {
+ 0x80108020,0x80008000,0x00008000,0x00108020,
+ 0x00100000,0x00000020,0x80100020,0x80008020,
+ 0x80000020,0x80108020,0x80108000,0x80000000,
+@@ -34,6 +36,7 @@
+ 0x00100020,0x80008020,0x80000020,0x00100020,
+ 0x00108000,0x00000000,0x80008000,0x00008020,
+ 0x80000000,0x80100020,0x80108020,0x00108000,
++}, {
+ 0x00000208,0x08020200,0x00000000,0x08020008,
+ 0x08000200,0x00000000,0x00020208,0x08000200,
+ 0x00020008,0x08000008,0x08000008,0x00020000,
+@@ -50,6 +53,7 @@
+ 0x00000008,0x00020208,0x00020200,0x08000008,
+ 0x08020000,0x08000208,0x00000208,0x08020000,
+ 0x00020208,0x00000008,0x08020008,0x00020200,
++}, {
+ 0x00802001,0x00002081,0x00002081,0x00000080,
+ 0x00802080,0x00800081,0x00800001,0x00002001,
+ 0x00000000,0x00802000,0x00802000,0x00802081,
+@@ -66,6 +70,7 @@
+ 0x00800001,0x00002001,0x00802080,0x00800081,
+ 0x00002001,0x00002080,0x00800000,0x00802001,
+ 0x00000080,0x00800000,0x00002000,0x00802080,
++}, {
+ 0x00000100,0x02080100,0x02080000,0x42000100,
+ 0x00080000,0x00000100,0x40000000,0x02080000,
+ 0x40080100,0x00080000,0x02000100,0x40080100,
+@@ -82,6 +87,7 @@
+ 0x02080000,0x00000000,0x40080000,0x42000000,
+ 0x00080100,0x02000100,0x40000100,0x00080000,
+ 0x00000000,0x40080000,0x02080100,0x40000100,
++}, {
+ 0x20000010,0x20400000,0x00004000,0x20404010,
+ 0x20400000,0x00000010,0x20404010,0x00400000,
+ 0x20004000,0x00404010,0x00400000,0x20000010,
+@@ -98,6 +104,7 @@
+ 0x00000010,0x00004000,0x20400000,0x00404010,
+ 0x00004000,0x00400010,0x20004010,0x00000000,
+ 0x20404000,0x20000000,0x00400010,0x20004010,
++}, {
+ 0x00200000,0x04200002,0x04000802,0x00000000,
+ 0x00000800,0x04000802,0x00200802,0x04200800,
+ 0x04200802,0x00200000,0x00000000,0x04000002,
+@@ -114,6 +121,7 @@
+ 0x00200800,0x00000000,0x00000002,0x04200802,
+ 0x00000000,0x00200802,0x04200000,0x00000800,
+ 0x04000002,0x04000800,0x00000800,0x00200002,
++}, {
+ 0x10001040,0x00001000,0x00040000,0x10041040,
+ 0x10000000,0x10001040,0x00000040,0x10000000,
+ 0x00040040,0x10040000,0x10041040,0x00041000,
+@@ -130,4 +138,5 @@
+ 0x10040000,0x10001000,0x10001040,0x00000000,
+ 0x10041040,0x00041000,0x00041000,0x00001040,
+ 0x00001040,0x00040040,0x10000000,0x10041000,
++},
+ };