aboutsummaryrefslogtreecommitdiffstats
path: root/security/snoopy
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-24 03:06:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-24 03:06:06 +0800
commit954f21a4f9ed191c1eee0164ad99ef8105798cc0 (patch)
tree83af10560c4cfb3110a3c4ec855a837a8626d73d /security/snoopy
parentd137984413843e7d5fc96c9744e829e530c16707 (diff)
downloadfreebsd-ports-graphics-954f21a4f9ed191c1eee0164ad99ef8105798cc0.tar.gz
freebsd-ports-graphics-954f21a4f9ed191c1eee0164ad99ef8105798cc0.tar.zst
freebsd-ports-graphics-954f21a4f9ed191c1eee0164ad99ef8105798cc0.zip
- Remove leading indefinite article from COMMENT
- Remove LICENSE_FILE for well-known licenses - Add OPTIONS_DEFINE - Support STAGEDIR - Take maintainership
Diffstat (limited to 'security/snoopy')
-rw-r--r--security/snoopy/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/security/snoopy/Makefile b/security/snoopy/Makefile
index c9c877fdbf3..36bd42ecc98 100644
--- a/security/snoopy/Makefile
+++ b/security/snoopy/Makefile
@@ -6,19 +6,19 @@ PORTVERSION= 1.8.0
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}logger/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An execve() wrapper and logger
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= execve() wrapper and logger
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS_DEFINE= DOCS
PLIST_FILES= lib/snoopy.so bin/detect
PORTDOCS= README
-USES= gmake
GNU_CONFIGURE= yes
+USES= gmake
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -26,11 +26,11 @@ post-patch:
@${REINPLACE_CMD} '/^LIBS.*/d' ${WRKSRC}/Makefile.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/snoopy.so ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/detect ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/detect ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/snoopy.so ${STAGEDIR}${PREFIX}/lib/
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>