aboutsummaryrefslogtreecommitdiffstats
path: root/security/tripwire-131/Makefile
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2000-07-06 22:15:53 +0800
committersada <sada@FreeBSD.org>2000-07-06 22:15:53 +0800
commit15ecb3e7d5c25e61603688e0ee603795120e91ea (patch)
tree98563f4b707b988af580ef1810447a0ece1a75c5 /security/tripwire-131/Makefile
parent34c70114a854ba7559be32acc1e0f16012dff5a6 (diff)
downloadfreebsd-ports-graphics-15ecb3e7d5c25e61603688e0ee603795120e91ea.tar.gz
freebsd-ports-graphics-15ecb3e7d5c25e61603688e0ee603795120e91ea.tar.zst
freebsd-ports-graphics-15ecb3e7d5c25e61603688e0ee603795120e91ea.zip
Upgrade to 1.3.1, beta version.
PR: 18964 Submitted by: Cy Schubert <Cy.Schubert@uumail.gov.bc.ca>
Diffstat (limited to 'security/tripwire-131/Makefile')
-rw-r--r--security/tripwire-131/Makefile45
1 files changed, 20 insertions, 25 deletions
diff --git a/security/tripwire-131/Makefile b/security/tripwire-131/Makefile
index a54f61ea8e4..d0a57cfab09 100644
--- a/security/tripwire-131/Makefile
+++ b/security/tripwire-131/Makefile
@@ -1,57 +1,52 @@
-# New ports collection makefile for: tripwire
-# Date created: 31 Mar 1997
-# Whom: Joe Greco <jgreco@ns.sol.net>
+# New ports collection makefile for: tripwire 1.3.1
+# Date created: Fri Mar 19 18:29:18 1999
+# Whom: Cy Schubert <Cy.Schubert@uumail.gov.bc.ca>
#
# $FreeBSD$
#
-PORTNAME= tripwire
-PORTVERSION= 1.2
+PORTNAME= tripwire
+PORTVERSION= 1.3.1
CATEGORIES= security
-MASTER_SITES= ftp://ftp.fu-berlin.de/unix/security/tripwire/
-EXTRACT_SUFX= .tar.Z
+DISTNAME= Tripwire-${PORTVERSION}-1
-MAINTAINER= jgreco@ns.sol.net
+MAINTAINER= Cy.Schubert@uumail.gov.bc.ca
MAN5= tw.config.5
MAN8= siggen.8 tripwire.8
NO_CDROM= "cannot be redistributed for more than the cost of duplication"
NO_PACKAGE= "requires local database to be built"
RESTRICTED= "contains crypto class algorithms"
+WRKSRC= ${WRKDIR}/tw_ASR_1.3.1_src
-post-extract:
- @ (cd ${WRKDIR}; tar xpf T1.2.tar)
+.include <bsd.port.pre.mk>
-post-patch:
- @${PERL} -pi -e 's|/secureplace/bin|${PREFIX}/bin|g;' \
- -e 's|/usr/man|${PREFIX}/man|g;' ${WRKSRC}/Makefile
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE='Please read http://www.tripwiresecurity.com/ for details of how to obtain the Tripwire source. Put the file ${DISTNAME}${EXTRACT_SUFX} into the directory ${DISTDIR} and run make again.'
+.endif
pre-configure:
@ ${CP} ${FILESDIR}/conf-freebsd2.h ${WRKSRC}/configs
- @ ${SED} s%/kernel%`sysctl -bn kern.bootfile`% \
- < ${FILESDIR}/tw.conf.freebsd2 \
- > ${WRKSRC}/configs/tw.conf.freebsd2
+ @ ${CP} ${FILESDIR}/tw.conf.freebsd2 ${WRKSRC}/configs/tw.conf.freebsd2
post-install:
@ ${MKDIR} /var/adm/tcheck
@ ${CP} ${FILESDIR}/tw.conf.freebsd2 /var/adm/tcheck/tw.config
- # Creating tripwire database
+ @ ${ECHO} Creating tripwire database
@ (cd /var/adm/tcheck; tripwire -initialize)
.if defined(TRIPWIRE_FLOPPY) && ${TRIPWIRE_FLOPPY} == YES
- # preparing the floppy
@ disklabel -w -B /dev/rfd0c fd1440
@ newfs -u 0 -t 0 -i 196608 -m 0 -T minimum -o space /dev/rfd0c
- mount /dev/fd0c /mnt
- # transferring things to the floppy
+ @ mount /dev/fd0c /mnt
+ @ ${GZIP_CMD} < ${PREFIX}/bin/tripwire > /mnt/tripwire
@ ${CP} -p /var/adm/tcheck/tw.config /mnt/tw.config
@ ${GZIP_CMD} < /var/adm/tcheck/databases/tw.db_`hostname` \
> /mnt/tw.db_`hostname`.gz
- @ ${CP} -p ${FILESDIR}/twcheck /usr/bin/gunzip \
- ${PREFIX}/bin/tripwire \
- /mnt/
+ @ ${CP} -p ${FILESDIR}/twcheck /mnt/twcheck
+ @ ${GZIP_CMD} < /usr/bin/gunzip > /mnt/gunzip
@ ${CHMOD} 555 /mnt/tripwire /mnt/gunzip /mnt/twcheck
@ umount /mnt
- # Do not forget to remove and write-protect the floppy.
+ @ ${ECHO} Do not forget to remove and write-protect the floppy.
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>