aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-10-26 17:29:39 +0800
committerjhale <jhale@FreeBSD.org>2012-10-26 17:29:39 +0800
commit0465a7d5d4b5cddd06fb66c4e7ae1ae82b4cc31a (patch)
tree247ed343b248019fbb061e81b41d613f9fad6427 /security
parentd9832644b010da67b341a0e03bfcda6d896d6728 (diff)
downloadfreebsd-ports-graphics-0465a7d5d4b5cddd06fb66c4e7ae1ae82b4cc31a.tar.gz
freebsd-ports-graphics-0465a7d5d4b5cddd06fb66c4e7ae1ae82b4cc31a.tar.zst
freebsd-ports-graphics-0465a7d5d4b5cddd06fb66c4e7ae1ae82b4cc31a.zip
- Update MASTER_SITES
- Remove DEPRECATED/EXPIRATION_DATE as port fetches now - Use PORTDOCS macro and PLIST_FILES instead of 4 line pkg-plist - Convert to new options framework - Trim Makefile header - Remove dead WWW from pkg-descr - Rename patch-aa to patch-zz.c PR: ports/172065 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Approved by: makc, avilla (mentors, implicit) Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/zombiezapper/Makefile30
-rw-r--r--security/zombiezapper/files/patch-zz.c (renamed from security/zombiezapper/files/patch-aa)0
-rw-r--r--security/zombiezapper/pkg-descr2
-rw-r--r--security/zombiezapper/pkg-plist4
4 files changed, 15 insertions, 21 deletions
diff --git a/security/zombiezapper/Makefile b/security/zombiezapper/Makefile
index 43c3a298c72..0021dfe07fb 100644
--- a/security/zombiezapper/Makefile
+++ b/security/zombiezapper/Makefile
@@ -1,38 +1,38 @@
-# Ports collection makefile for: zombiezapper
-# Date created: 19 Feb 2000
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= zombiezapper
PORTVERSION= 1.2
PORTREVISION= 2
CATEGORIES= security
-MASTER_SITES= http://razor.bindview.com/tools/files/
+MASTER_SITES= PACKETSTORM/distributed/zombie
DISTNAME= zombie-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Send a terminate command to Trinoo/TFN/Stacheldracht DDoS agents
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-10-20
-
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+CPPFLAGS+= $$(${LIBNET_CONFIG} --cflags --defines)
+LDFLAGS+= $$(${LIBNET_CONFIG} --libs)
+
+PORTDOCS= USAGE tekpaper.txt
+PLIST_FILES= bin/zz
+
+.include <bsd.port.options.mk>
+
do-build:
cd ${WRKSRC} && \
- ${CC} ${CFLAGS} -o zz zz.c `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --libs`
+ ${CC} ${CFLAGS} ${CPPFLAGS} -o zz zz.c ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/zz ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/zz/
- ${INSTALL_DATA} ${WRKSRC}/USAGE ${PREFIX}/share/doc/zz/
- ${INSTALL_DATA} ${WRKSRC}/tekpaper.txt ${PREFIX}/share/doc/zz/
+ ${INSTALL_PROGRAM} ${WRKSRC}/zz ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/security/zombiezapper/files/patch-aa b/security/zombiezapper/files/patch-zz.c
index 0af2526c6ee..0af2526c6ee 100644
--- a/security/zombiezapper/files/patch-aa
+++ b/security/zombiezapper/files/patch-zz.c
diff --git a/security/zombiezapper/pkg-descr b/security/zombiezapper/pkg-descr
index 1ef81fb0a32..a967d2fb5f5 100644
--- a/security/zombiezapper/pkg-descr
+++ b/security/zombiezapper/pkg-descr
@@ -8,5 +8,3 @@ advantage of telling the daemon to stop flooding without stopping
the daemon, allowing you to take a little more time in tracking down
where they are, and more importantly, how they got there in the first
place.
-
-WWW: http://razor.bindview.com/tools/ZombieZapper_form.shtml
diff --git a/security/zombiezapper/pkg-plist b/security/zombiezapper/pkg-plist
deleted file mode 100644
index 51f784f57b7..00000000000
--- a/security/zombiezapper/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/zz
-%%PORTDOCS%%share/doc/zz/USAGE
-%%PORTDOCS%%share/doc/zz/tekpaper.txt
-%%PORTDOCS%%@dirrm share/doc/zz