aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-12-31 19:14:19 +0800
committerlioux <lioux@FreeBSD.org>2004-12-31 19:14:19 +0800
commit20836ba57494eea8f6346da868c89daa657a4e78 (patch)
tree73f1a3e6991bad4fa81ad28247e00527bf6ba4c0 /security
parent38f3242dc921d6292b34293a767b5b2af8b99375 (diff)
downloadfreebsd-ports-graphics-20836ba57494eea8f6346da868c89daa657a4e78.tar.gz
freebsd-ports-graphics-20836ba57494eea8f6346da868c89daa657a4e78.tar.zst
freebsd-ports-graphics-20836ba57494eea8f6346da868c89daa657a4e78.zip
o Update to <bsd.java.mk> standard 2.0
o Bump PORTREVISION due to jar location changes Prompted by: hq
Diffstat (limited to 'security')
-rw-r--r--security/gnu-crypto/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/security/gnu-crypto/Makefile b/security/gnu-crypto/Makefile
index f73882177c4..b802e8258f1 100644
--- a/security/gnu-crypto/Makefile
+++ b/security/gnu-crypto/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnu-crypto
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= security java
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,7 +30,6 @@ USE_JAVA= yes
JAVA_VERSION= 1.4+
USE_ANT= yes
-JAR_DIR= share/java/jar/${PORTNAME}
JAR_FILES= \
javax-crypto.jar \
javax-security.jar \
@@ -39,11 +39,9 @@ INFO= gnu-crypto
MAKEINFOFLAGS= --no-split
.for jar in ${JAR_FILES}
-PLIST_FILES+= ${JAR_DIR}/${jar}
+PLIST_FILES+= %%JAVAJARDIR%%/${jar}
.endfor
-PLIST_DIRS+= ${JAR_DIR}
-
post-extract:
@${RM} ${WRKSRC}/docs/*.info*
@@ -56,9 +54,8 @@ post-build:
@cd ${WRKSRC}/docs && ${GMAKE} all
do-install:
- @${MKDIR} ${PREFIX}/${JAR_DIR}
.for jar in ${JAR_FILES}
- @${INSTALL_DATA} ${WRKSRC}/lib/${jar} ${PREFIX}/${JAR_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${jar} ${JAVAJARDIR}
.endfor
@${MKDIR} ${PREFIX}/${INFO_PATH}
@${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.info \