aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-06-27 03:49:15 +0800
committerpawel <pawel@FreeBSD.org>2015-06-27 03:49:15 +0800
commit2ab1f4a6dce71263813ba5132a7a003d437b6a57 (patch)
treee8bb59147b3a60b525ac0a8dfdd50011b471c6be /security
parent7160e4b0022ce7487fc1d1aa3a6dfdbd5c83e2aa (diff)
downloadfreebsd-ports-graphics-2ab1f4a6dce71263813ba5132a7a003d437b6a57.tar.gz
freebsd-ports-graphics-2ab1f4a6dce71263813ba5132a7a003d437b6a57.tar.zst
freebsd-ports-graphics-2ab1f4a6dce71263813ba5132a7a003d437b6a57.zip
- Make xsel run dependency optional - it makes clipboard pasting
not working under some conditions [1] - Make xdotool also optional - Add NO_ARCH PR: 200931 [1] Submitted by: Sascha Holzleiter <sascha@root-login.org> [1] Approved by: maintainer [1]
Diffstat (limited to 'security')
-rw-r--r--security/keepass/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/keepass/Makefile b/security/keepass/Makefile
index f70c717f603..1c88cef4667 100644
--- a/security/keepass/Makefile
+++ b/security/keepass/Makefile
@@ -15,8 +15,6 @@ LICENSE= GPLv2 # or later
BUILD_DEPENDS= icotool:${PORTSDIR}/graphics/icoutils
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgdiplus.so:${PORTSDIR}/x11-toolkits/libgdiplus
-RUN_DEPENDS= xdotool:${PORTSDIR}/x11/xdotool \
- xsel:${PORTSDIR}/x11/xsel
EXTRACT_AFTER_ARGS= -d ${WRKDIR}/${DISTNAME}
@@ -25,6 +23,8 @@ DOS2UNIX_GLOB= *.csproj *.sln
INSTALLS_ICONS= yes
SUB_FILES= ${PORTNAME}.sh
+NO_ARCH= yes
+
DESKTOP_ENTRIES="KeePass" \
"${COMMENT}" \
"${PORTNAME}" \
@@ -32,6 +32,15 @@ DESKTOP_ENTRIES="KeePass" \
"Utility;" \
true
+OPTIONS_DEFINE= XDOTOOL XSEL
+XDOTOOL_DESC= Use the xdotool utility for auto-typing passwords
+XSEL_DESC= Use the xsel utility for clipboard copying
+
+OPTIONS_DEFAULT= XDOTOOL XSEL
+
+XDOTOOL_RUN_DEPENDS= xdotool:${PORTSDIR}/x11/xdotool
+XSEL_RUN_DEPENDS= xsel:${PORTSDIR}/x11/xsel
+
do-build:
# Extract icons
(cd ${WRKSRC} && ${LOCALBASE}/bin/icotool -x KeePass/KeePass.ico)