aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-10-18 21:07:10 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-10-18 21:07:10 +0800
commit4262929ef5a173eff391152297b537aee3567d7c (patch)
tree42562ccb477320e63f3d6b990ac29ba2bc61649f /security
parent83d493a4f4b1ad7e84fad43411bebe7a264f6022 (diff)
downloadfreebsd-ports-graphics-4262929ef5a173eff391152297b537aee3567d7c.tar.gz
freebsd-ports-graphics-4262929ef5a173eff391152297b537aee3567d7c.tar.zst
freebsd-ports-graphics-4262929ef5a173eff391152297b537aee3567d7c.zip
- Add LICENSE
- Support OPTIONS - Support USE_TK_WRAPPER - Support ECHO_CMD - Support MAKE_JOBS_UNSAFE PR: 161601 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'security')
-rw-r--r--security/openfwtk/Makefile74
1 files changed, 41 insertions, 33 deletions
diff --git a/security/openfwtk/Makefile b/security/openfwtk/Makefile
index 94076c91197..aa23880841f 100644
--- a/security/openfwtk/Makefile
+++ b/security/openfwtk/Makefile
@@ -6,66 +6,74 @@
PORTNAME= openfwtk
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Release%20${PORTVERSION}
-DISTNAME=${PORTNAME}${PORTVERSION}
+DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Application proxy toolkit which inherits the ideology of TIS fwtk
-WRKSRC= ${WRKDIR}/fwtk
+LICENSE= BSD
+
+OPTIONS= WATCH "Install fw-watch GUI (require TCL/TK!)" off
+
+WRKSRC= ${WRKDIR}/fwtk
WRKSRC_WATCH= ${WRKDIR}/fw_watch
WRKSRC_MILTER= ${WRKDIR}/libci_milter
-OPTIONS= WATCH "Install fw-watch GUI (require TCL/TK!)" off
+MAKE_JOBS_UNSAFE=yes
SUB_FILES= pkg-message
MANCOMPRESSED= no
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 900007
-BROKEN= fails to build with new utmpx
-.endif
+.include <bsd.port.options.mk>
.if defined(WITH_WATCH)
+USE_TK_WRAPPER= yes
PLIST_SUB+= WATCH=""
-RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
.else
PLIST_SUB+= WATCH="@comment "
.endif
-BUILD_DIRS= ${WRKSRC_MILTER} ${WRKSRC}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
-do-build:
-.for i in ${BUILD_DIRS}
- (cd ${WRKDIR}/${i}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+post-patch:
+.for conf in auth/authadduser.sh reports/summ_resources.sh \
+ reports/daily_report reports/frequentcheck \
+ reports/frequentcheck.sh squid-gw/squid-gw.restart
+ @${REINPLACE_CMD} -e \
+ 's|/etc/openfwtk.conf|${PREFIX}/etc/openfwtk.conf|g' ${WRKSRC}/${conf}
.endfor
+.for wish in fileselect.tcl fw_watch
+ @${REINPLACE_CMD} -e \
+ 's|/usr/bin/|${LOCALBASE}/bin/|g' ${WRKSRC_WATCH}/${wish}
+.endfor
+ @${REINPLACE_CMD} -e \
+ '/^CC/s|=.*|= ${CC}|g ; \
+ /^COPT/s|=.*|= ${CFLAGS}|g' ${WRKSRC_MILTER}/Makefile
+ @${REINPLACE_CMD} -e \
+ '/^CC/s|=.*|= ${CC}|g ; \
+ /^COPT/s|-std=c99|${CFLAGS}|g' ${WRKSRC}/configs/FreeBSD
+
+pre-build:
+ @(cd ${WRKSRC_MILTER}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
-post-build:
- @${REINPLACE_CMD} -e 's|/etc/openfwtk.conf|${PREFIX}/etc/openfwtk.conf|g' \
- ${WRKSRC}/reports/summ_resources.sh ${WRKSRC}/reports/daily_report \
- ${WRKSRC}/reports/frequentcheck.sh ${WRKSRC}/reports/frequentcheck \
- ${WRKSRC}/auth/authadduser.sh ${WRKSRC}/squid-gw/squid-gw.restart \
- ${WRKSRC}/reports/daily_report ${WRKSRC}/reports/frequentcheck
pre-install:
- ${MKDIR} ${ETCDIR}
+ @${MKDIR} ${ETCDIR}
+
post-install:
.if defined(WITH_WATCH)
- ${MKDIR} ${PREFIX}/share/fw_watch
- @${REINPLACE_CMD} -e 's|/usr/bin/wish|${PREFIX}/bin/wish8.4|g' \
- ${WRKSRC_WATCH}/fileselect.tcl \
- ${WRKSRC_WATCH}/fw_watch \
- ${WRKSRC_WATCH}/newsb.tcl \
- ${WRKSRC_WATCH}/searchbox.tcl \
- ${WRKSRC_WATCH}/taputils.tcl
- ${CP} ${WRKSRC_WATCH}/fileselect.tcl ${PREFIX}/share/fw_watch/
- ${CP} ${WRKSRC_WATCH}/fw_watch ${PREFIX}/share/fw_watch/
- ${CP} ${WRKSRC_WATCH}/newsb.tcl ${PREFIX}/share/fw_watch/
- ${CP} ${WRKSRC_WATCH}/searchbox.tcl ${PREFIX}/share/fw_watch/
- ${CP} ${WRKSRC_WATCH}/taputils.tcl ${PREFIX}/share/fw_watch/
+ @${MKDIR} ${PREFIX}/share/fw_watch
+.for data in fileselect.tcl fw_watch newsb.tcl searchbox.tcl taputils.tcl
+ ${INSTALL_DATA} ${WRKSRC_WATCH}/${data} ${PREFIX}/share/fw_watch
+.endfor
.endif
- ${ECHO} "root@`hostname`" > ${ETCDIR}/admin
+ ${ECHO_CMD} "root@`hostname`" > ${ETCDIR}/admin
@${CAT} ${PKGMESSAGE}
.include "Makefile.man"