aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-19 05:55:15 +0800
committererwin <erwin@FreeBSD.org>2005-12-19 05:55:15 +0800
commit473ff650f30f9e74e7ffc2d7c87e78cff46cd670 (patch)
treed36966de1f97ef5ae137b6bde0e4c38115a49b1e /security
parent4cb940eb45415d366a18a83b0897152b87a5015b (diff)
downloadfreebsd-ports-graphics-473ff650f30f9e74e7ffc2d7c87e78cff46cd670.tar.gz
freebsd-ports-graphics-473ff650f30f9e74e7ffc2d7c87e78cff46cd670.tar.zst
freebsd-ports-graphics-473ff650f30f9e74e7ffc2d7c87e78cff46cd670.zip
Generic CFB implementation in pure Perl. The Cipher Feedback Mode module
constructs a stream cipher from a block cipher or cryptographic hash funtion and returns it as an object. Any block cipher in the Crypt:: class can be used, as long as it supports the blocksize and keysize methods. Any hash function in the Digest:: class can be used, as long as it supports the add method. WWW: http://search.cpan.org/dist/Crypt-CFB PR: ports/90611 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-CFB/Makefile24
-rw-r--r--security/p5-Crypt-CFB/distinfo3
-rw-r--r--security/p5-Crypt-CFB/pkg-descr8
-rw-r--r--security/p5-Crypt-CFB/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f5dd240ca28..158d1d6774d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -288,6 +288,7 @@
SUBDIR += p5-Crypt-CAST5_PP
SUBDIR += p5-Crypt-CBC
SUBDIR += p5-Crypt-CBCeasy
+ SUBDIR += p5-Crypt-CFB
SUBDIR += p5-Crypt-CipherSaber
SUBDIR += p5-Crypt-Cracklib
SUBDIR += p5-Crypt-Cryptix
diff --git a/security/p5-Crypt-CFB/Makefile b/security/p5-Crypt-CFB/Makefile
new file mode 100644
index 00000000000..5a0c6bc9ec9
--- /dev/null
+++ b/security/p5-Crypt-CFB/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-CFB
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-CFB
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for encrypting data in Cipher Feedback Mode
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::CFB.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-CFB/distinfo b/security/p5-Crypt-CFB/distinfo
new file mode 100644
index 00000000000..a9a8ce4ab01
--- /dev/null
+++ b/security/p5-Crypt-CFB/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-CFB-0.01.tar.gz) = eb29e4d92d67b7763a3882858077cf08
+SHA256 (Crypt-CFB-0.01.tar.gz) = 2ee25f51f360779759b48e7703a77a4436f5ce278ac8e8077bff5f8c62fa2b78
+SIZE (Crypt-CFB-0.01.tar.gz) = 8572
diff --git a/security/p5-Crypt-CFB/pkg-descr b/security/p5-Crypt-CFB/pkg-descr
new file mode 100644
index 00000000000..3a99acb1e00
--- /dev/null
+++ b/security/p5-Crypt-CFB/pkg-descr
@@ -0,0 +1,8 @@
+Generic CFB implementation in pure Perl. The Cipher Feedback Mode module
+constructs a stream cipher from a block cipher or cryptographic hash funtion
+and returns it as an object. Any block cipher in the Crypt:: class can be
+used, as long as it supports the blocksize and keysize methods. Any hash
+function in the Digest:: class can be used, as long as it supports the
+add method.
+
+WWW: http://search.cpan.org/dist/Crypt-CFB
diff --git a/security/p5-Crypt-CFB/pkg-plist b/security/p5-Crypt-CFB/pkg-plist
new file mode 100644
index 00000000000..055080039c5
--- /dev/null
+++ b/security/p5-Crypt-CFB/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/CFB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/CFB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/CFB/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true