aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-03-08 07:10:45 +0800
committersylvio <sylvio@FreeBSD.org>2010-03-08 07:10:45 +0800
commit587a96b770832f196010ccf3de361e4a47164637 (patch)
tree70d3c802ff040e8e6a337a55e703f7caea8e4d63 /security
parent5b09b6daf56b9488c791b984696913cfd6b5356a (diff)
downloadfreebsd-ports-graphics-587a96b770832f196010ccf3de361e4a47164637.tar.gz
freebsd-ports-graphics-587a96b770832f196010ccf3de361e4a47164637.tar.zst
freebsd-ports-graphics-587a96b770832f196010ccf3de361e4a47164637.zip
- Unbreak
- Add a MASTER_SITES - Add OPTIONS to the GUI - Pass maintainership to submitter. PR: ports/143639 Submitted by: Rob Farmer <rfarmer@predatorlabs.net> Approved by: itetcu (mentor) Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/stegdetect/Makefile13
-rw-r--r--security/stegdetect/files/patch-xsteg.c32
2 files changed, 40 insertions, 5 deletions
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index f25424e6524..62e40d016c2 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -7,20 +7,23 @@
PORTNAME= stegdetect
PORTVERSION= 0.6
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= security
MASTER_SITES= http://www.outguess.org/ \
- http://distfiles.master.finkmirrors.net/
+ http://distfiles.master.finkmirrors.net/ \
+ http://www.predatorlabs.net/dl/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rfarmer@predatorlabs.net
COMMENT= Automated tool for detecting steganographic content in JPEGs
+OPTIONS= X11 "Build xsteg" On
+
+.include <bsd.port.options.mk>
+
.if !defined(WITHOUT_X11)
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
.endif
-BROKEN= does not build
-
# Note: stegdetect includes a modified version of jpeg-6b linked statically
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/security/stegdetect/files/patch-xsteg.c b/security/stegdetect/files/patch-xsteg.c
new file mode 100644
index 00000000000..23ff6c10386
--- /dev/null
+++ b/security/stegdetect/files/patch-xsteg.c
@@ -0,0 +1,32 @@
+--- xsteg.c.orig 2010-02-07 02:37:05.398520068 -0800
++++ xsteg.c 2010-02-07 02:38:33.877232865 -0800
+@@ -56,9 +56,6 @@
+ #define FLAG_DOINVIS 0x0008
+ #define FLAG_DOF5 0x0010
+
+-extern int (*event_sigcb)(void);
+-extern int event_gotsig;
+-
+ struct event start_ev;
+ struct event gtk_ev;
+ int quit = 0;
+@@ -744,8 +741,7 @@
+ sigprocmask(SIG_BLOCK, &set, &oldset);
+
+ while ((pid = waitpid(-1, &status, WNOHANG)) > 0) {
+- if (WIFEXITED(status) || WIFSIGNALED(status))
+- event_gotsig = 1;
++ ;
+ }
+
+ signal(SIGCHLD, chld_handler);
+@@ -1106,8 +1102,7 @@
+ gtk_widget_show(window);
+
+ event_init();
+- event_sigcb = signal_cb;
+-
++
+ add_gtk_timeout();
+
+ event_dispatch();