aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-06-06 04:44:14 +0800
committerpav <pav@FreeBSD.org>2005-06-06 04:44:14 +0800
commit5a1fb23cd01f3adb272b346ce74950dd10a9fe49 (patch)
treed777ad3a996732d3ec8e027b845a0b577f63ecf6 /security
parent686ee8da1a1bb41fd4b52eb8efdf384df5f3ca6c (diff)
downloadfreebsd-ports-graphics-5a1fb23cd01f3adb272b346ce74950dd10a9fe49.tar.gz
freebsd-ports-graphics-5a1fb23cd01f3adb272b346ce74950dd10a9fe49.tar.zst
freebsd-ports-graphics-5a1fb23cd01f3adb272b346ce74950dd10a9fe49.zip
- Update to 0.3.6
PR: ports/81669 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru> Approved by: maintainer timeout (16 days)
Diffstat (limited to 'security')
-rw-r--r--security/samba-vscan/Makefile26
-rw-r--r--security/samba-vscan/distinfo4
-rw-r--r--security/samba-vscan/files/patch-configure95
-rw-r--r--security/samba-vscan/files/patch-vscan-clamav.h22
-rw-r--r--security/samba-vscan/files/patch-vscan-fsav.h10
-rw-r--r--security/samba-vscan/files/patch-vscan-sophos.h19
-rw-r--r--security/samba-vscan/files/patch-vscan-trend.h19
-rw-r--r--security/samba-vscan/pkg-plist1
8 files changed, 149 insertions, 47 deletions
diff --git a/security/samba-vscan/Makefile b/security/samba-vscan/Makefile
index b836adab638..6812e01c114 100644
--- a/security/samba-vscan/Makefile
+++ b/security/samba-vscan/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= samba-vscan
-PORTVERSION= 0.3.5
-PORTREVISION= 1
+PORTVERSION= 0.3.6
CATEGORIES= security
-MASTER_SITES= http://heanet.dl.sourceforge.net/sourceforge/openantivirus/ \
- http://easynews.dl.sourceforge.net/sourceforge/openantivirus/ \
- http://flow.dl.sourceforge.net/sourceforge/openantivirus/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= openantivirus
MAINTAINER= jmelo@freebsdbrasil.com.br
COMMENT= On-access virus scanning with Samba
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/${VSCAN_SAMBA_PORT}:build
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/${VSCAN_SAMBA_PORT}:configure
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README
+.endif
USE_BZIP2= yes
SAMBA_WRKSRC= `cd ${PORTSDIR}/net/${VSCAN_SAMBA_PORT}; make -V WRKSRC`
@@ -25,7 +26,7 @@ USE_GMAKE= yes
CONFIGURE_ARGS= --with-samba-source=${SAMBA_WRKSRC}
ETCDIR= ${PREFIX}/etc/samba-vscan
PKGMESSAGE= ${WRKDIR}/pkg-message
-VSCAN_SAMBA_PORT?=samba
+VSCAN_SAMBA_PORT?=samba3
.if ${VSCAN_SAMBA_PORT} == "samba3"
PLIST_SUB= VFSDIR=lib/samba/vfs
@@ -33,7 +34,18 @@ PLIST_SUB= VFSDIR=lib/samba/vfs
PLIST_SUB= VFSDIR=lib/samba
.endif
+pre-configure:
+.if ${VSCAN_SAMBA_PORT} == "samba3"
+ @cd ${SAMBA_WRKSRC}; make proto 2>&1 > /dev/null
+.endif
+
post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
@${MKDIR} ${PREFIX}/etc/samba-vscan
@${INSTALL_DATA} ${WRKSRC}/clamav/vscan-clamav.conf ${ETCDIR}
@${INSTALL_DATA} ${WRKSRC}/fprot/vscan-fprotd.conf ${ETCDIR}
diff --git a/security/samba-vscan/distinfo b/security/samba-vscan/distinfo
index 35d8d714362..ad07a77241a 100644
--- a/security/samba-vscan/distinfo
+++ b/security/samba-vscan/distinfo
@@ -1,2 +1,2 @@
-MD5 (samba-vscan-0.3.5.tar.bz2) = 5f173d549014985d681478897135915b
-SIZE (samba-vscan-0.3.5.tar.bz2) = 161982
+MD5 (samba-vscan-0.3.6.tar.bz2) = 68c9d099d942d85e68d96804b26ac788
+SIZE (samba-vscan-0.3.6.tar.bz2) = 166733
diff --git a/security/samba-vscan/files/patch-configure b/security/samba-vscan/files/patch-configure
new file mode 100644
index 00000000000..0b25076397e
--- /dev/null
+++ b/security/samba-vscan/files/patch-configure
@@ -0,0 +1,95 @@
+--- configure.orig Thu Mar 24 00:31:42 2005
++++ configure Mon May 30 16:58:31 2005
+@@ -3902,7 +3902,7 @@
+ #
+ # Try to get the Samba Version for old releases
+ #
+-SAMBA_VERSION_H_STR=$(cat ${SAMBA_srcdir}/include/version.h |grep '#define VERSION'|cut -d ' ' -f3-)
++SAMBA_VERSION_H_STR=`cat ${SAMBA_srcdir}/include/version.h |grep '#define SAMBA_VERSION'|cut -d ' ' -f3-`
+
+ SAMBA_VERSION=
+ ####################################################
+@@ -3950,26 +3950,21 @@
+ esac
+ fi;
+
+-
+-if test -z "$SAMBA_VERSION_STRING";then
++if /usr/bin/true ;then
+
+ if test -z "$SAMBA_VERSION"; then
+ SAMBA_VERSION=$SAMBA_VERSION_H_STR
+ fi
+-
+ echo "$as_me:$LINENO: checking for Samba Version" >&5
+ echo $ECHO_N "checking for Samba Version... $ECHO_C" >&6
+
+- SAMBA_VERSION_MAJOR=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\1/')
+- SAMBA_VERSION_MINOR=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\2/')
+- SAMBA_VERSION_RELEASE=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\3/')
+- SAMBA_VERSION_SUFFIX=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\4/')
+- SAMBA_VERSION_SUFFIX_RELEASE=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\5/')
+- SAMBA_VERSION_SUFFIX_EXTRA1=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\6/')
+- SAMBA_VERSION_SUFFIX_EXTRA2=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\8/')
++ SAMBA_VERSION_MAJOR=$(echo $SAMBA_VERSION | awk '{print $1}')
++ SAMBA_VERSION_MINOR=$(echo $SAMBA_VERSION | awk '{print $2}')
++ SAMBA_VERSION_RELEASE=$(echo $SAMBA_VERSION | awk '{print $3}'| sed -e 's/\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)/\1/')
++ SAMBA_VERSION_SUFFIX=$(echo $SAMBA_VERSION | awk '{print $3}' | sed -e 's/\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)/\2/')
++ SAMBA_VERSION_SUFFIX_RELEASE=$(echo $SAMBA_VERSION | awk '{print $3}' | sed -e 's/\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)/\3/')
+
+ SAMBA_VERSION_STRING="${SAMBA_VERSION_MAJOR}.${SAMBA_VERSION_MINOR}"
+-
+ if test -n "$SAMBA_VERSION_RELEASE";then
+ SAMBA_VERSION_STRING="${SAMBA_VERSION_STRING}.${SAMBA_VERSION_RELEASE}"
+ fi
+@@ -4085,9 +4080,9 @@
+ fi
+
+
+-cat >>confdefs.h <<_ACEOF
++#cat >>confdefs.h <<_ACEOF
+ #define SAMBA_VERSION_OFFICIAL_STRING $SAMBA_VERSION_STRING
+-_ACEOF
++#_ACEOF
+
+
+ if test -n "${SAMBA_VERSION_VENDOR_SUFFIX}";then
+@@ -4101,9 +4096,9 @@
+
+ SAMBA_VERSION_STRING="\"${SAMBA_VERSION_STRING}\""
+
+-cat >>confdefs.h <<_ACEOF
++#cat >>confdefs.h <<_ACEOF
+ #define SAMBA_VERSION_STRING $SAMBA_VERSION_STRING
+-_ACEOF
++#_ACEOF
+
+
+ echo "$as_me:$LINENO: result: $SAMBA_VERSION_STRING" >&5
+@@ -5128,7 +5123,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lmagic $LIBS"
++LIBS="-lmagic -lz $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
+@@ -5182,7 +5177,7 @@
+ #define HAVE_LIBMAGIC 1
+ _ACEOF
+
+- LIBS="-lmagic $LIBS"
++ LIBS="-lmagic -lz $LIBS"
+
+ fi
+
+@@ -5190,7 +5185,7 @@
+ if test x"$ac_cv_header_magic_h" = x"yes"; then
+ if test x"$ac_cv_lib_magic_magic_load" = x"yes"; then
+ vscan_cv_filetype=yes
+- MAGIC_LIB="-lmagic"
++ MAGIC_LIB="-lmagic -lz"
+ fi
+ fi
+ fi
diff --git a/security/samba-vscan/files/patch-vscan-clamav.h b/security/samba-vscan/files/patch-vscan-clamav.h
index 7471077373c..ab4cfcd3107 100644
--- a/security/samba-vscan/files/patch-vscan-clamav.h
+++ b/security/samba-vscan/files/patch-vscan-clamav.h
@@ -1,20 +1,16 @@
---- clamav/vscan-clamav.h.old Fri Aug 13 13:42:37 2004
-+++ clamav/vscan-clamav.h Fri Aug 13 13:43:24 2004
-@@ -7,7 +7,7 @@
-
- /* Clam AntiVirus (clamd) stuff:
- socket name of Clam daemon */
--#define VSCAN_CLAMD_SOCKET_NAME "/var/run/clamd"
-+#define VSCAN_CLAMD_SOCKET_NAME "/var/run/clamav/clamd"
-
- /* Clam AntiVirus (libclamav) stuff:
- maximum number of files in archive */
-@@ -20,7 +20,7 @@
+--- clamav/vscan-clamav.h.orig Wed Sep 29 20:36:09 2004
++++ clamav/vscan-clamav.h Mon May 30 15:24:08 2005
+@@ -9,11 +9,11 @@
/* default location of samba-style configuration file (needs Samba >= 2.2.4
or Samba 3.0 */
-#define PARAMCONF "/etc/samba/vscan-clamav.conf"
+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-clamav.conf"
+ /* Clam AntiVirus (clamd) stuff:
+ socket name of Clam daemon */
+-#define VSCAN_CLAMD_SOCKET_NAME "/var/run/clamd"
++#define VSCAN_CLAMD_SOCKET_NAME "/var/run/clamav/clamd"
- /* False = log only infected file, True = log every file access */
+ /* Clam AntiVirus (libclamav) stuff:
+ maximum number of files in archive */
diff --git a/security/samba-vscan/files/patch-vscan-fsav.h b/security/samba-vscan/files/patch-vscan-fsav.h
index f5bb6adcfa0..b209da0743c 100644
--- a/security/samba-vscan/files/patch-vscan-fsav.h
+++ b/security/samba-vscan/files/patch-vscan-fsav.h
@@ -1,15 +1,15 @@
---- f-secure/vscan-fsav.h.old Fri Aug 13 13:49:40 2004
-+++ f-secure/vscan-fsav.h Fri Aug 13 13:51:15 2004
-@@ -37,7 +37,7 @@
+--- f-secure/vscan-fsav.h.orig Wed Sep 29 20:36:09 2004
++++ f-secure/vscan-fsav.h Mon May 30 15:28:24 2005
+@@ -40,7 +40,7 @@
/* default location of samba-style configuration file (needs Samba >= 2.2.4 or Samba 3.0 */
-#define PARAMCONF "/etc/samba/vscan-fsav.conf"
+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-fsav.conf"
- #define VSCAN_MODULE_STR "vscan-fsav"
+ /* FSAV-related settings */
-@@ -114,13 +114,13 @@
+@@ -52,13 +52,13 @@
#define VSCAN_FSAV_CONNECT_ID 0
/* fsav configuration file */
diff --git a/security/samba-vscan/files/patch-vscan-sophos.h b/security/samba-vscan/files/patch-vscan-sophos.h
index 6ef6a7dacf1..cb54355b525 100644
--- a/security/samba-vscan/files/patch-vscan-sophos.h
+++ b/security/samba-vscan/files/patch-vscan-sophos.h
@@ -1,17 +1,16 @@
---- sophos/vscan-sophos.h.old Fri Aug 13 14:05:51 2004
-+++ sophos/vscan-sophos.h Fri Aug 13 14:07:07 2004
-@@ -8,12 +8,12 @@
-
- /* Sophie stuff:
- socket name of Sophie daemon */
--#define SOPHIE_SOCKET_NAME "/var/run/sophie"
-+#define SOPHIE_SOCKET_NAME "/var/run/sophie/sophie.sock"
-
+--- sophos/vscan-sophos.h.orig Tue Sep 28 20:42:51 2004
++++ sophos/vscan-sophos.h Mon May 30 15:31:29 2005
+@@ -9,11 +9,11 @@
/* default location of samba-style configuration file (needs Samba >= 2.2.4
or Samba 3.0 */
-#define PARAMCONF "/etc/samba/vscan-sophos.conf"
+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-sophos.conf"
+ /* Sophie stuff:
+ socket name of Sophie daemon */
+-#define SOPHIE_SOCKET_NAME "/var/run/sophie"
++#define SOPHIE_SOCKET_NAME "/var/run/sophie/sophie.sock"
+
+ /* End Configuration Section */
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-trend.h b/security/samba-vscan/files/patch-vscan-trend.h
index 48bb964b44b..b8e1887062c 100644
--- a/security/samba-vscan/files/patch-vscan-trend.h
+++ b/security/samba-vscan/files/patch-vscan-trend.h
@@ -1,17 +1,16 @@
---- trend/vscan-trend.h.old Fri Aug 13 14:12:27 2004
-+++ trend/vscan-trend.h Fri Aug 13 14:13:09 2004
-@@ -8,12 +8,12 @@
-
- /* Trophie stuff:
- socket name of Trophie daemon */
--#define TROPHIE_SOCKET_NAME "/var/run/trophie"
-+#define TROPHIE_SOCKET_NAME "/var/run/trophie/trophie.sock"
-
+--- trend/vscan-trend.h.orig Tue Sep 28 20:42:52 2004
++++ trend/vscan-trend.h Mon May 30 15:33:12 2005
+@@ -9,11 +9,11 @@
/* default location of samba-style configuration file (needs Samba >= 2.2.4
or Samba 3.0 */
-#define PARAMCONF "/etc/samba/vscan-trend.conf"
+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-trend.conf"
+ /* Trophie stuff:
+ socket name of Trophie daemon */
+-#define TROPHIE_SOCKET_NAME "/var/run/trophie"
++#define TROPHIE_SOCKET_NAME "/var/run/trophie/trophie.sock"
+
+ /* End Configuration Section */
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/pkg-plist b/security/samba-vscan/pkg-plist
index 8dc06babe7b..4d4a10ae169 100644
--- a/security/samba-vscan/pkg-plist
+++ b/security/samba-vscan/pkg-plist
@@ -16,6 +16,7 @@ etc/samba-vscan/vscan-trend.conf
%%VFSDIR%%/vscan-oav.so
%%VFSDIR%%/vscan-sophos.so
%%VFSDIR%%/vscan-trend.so
+%%VFSDIR%%/vscan-antivir.so
@unexec rmdir %D/%%VFSDIR%% 2>/dev/null || true
@unexec rmdir %D/lib/samba 2>/dev/null || true
@dirrm etc/samba-vscan