aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-12-17 23:57:48 +0800
committermadpilot <madpilot@FreeBSD.org>2013-12-17 23:57:48 +0800
commit69b2554bed0122e015565c363f4044d4485d0b95 (patch)
tree2e6c05bcb33baa90a3a6b140467c240476e865e2 /security
parent6dc3bc18f22316bb0f82b4b80de605516f6bd17c (diff)
downloadfreebsd-ports-graphics-69b2554bed0122e015565c363f4044d4485d0b95.tar.gz
freebsd-ports-graphics-69b2554bed0122e015565c363f4044d4485d0b95.tar.zst
freebsd-ports-graphics-69b2554bed0122e015565c363f4044d4485d0b95.zip
- Fix build on 10 and head due to new ld behavior
- Stagify PR: ports/184926 Submitted by: me Approved by: arved (maintainer, via email)
Diffstat (limited to 'security')
-rw-r--r--security/ssh_askpass_gtk2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/ssh_askpass_gtk2/Makefile b/security/ssh_askpass_gtk2/Makefile
index 24329682ff6..cc1cb4d4f4a 100644
--- a/security/ssh_askpass_gtk2/Makefile
+++ b/security/ssh_askpass_gtk2/Makefile
@@ -19,12 +19,12 @@ USES= pkgconfig
PLIST_FILES= bin/ssh-askpass-fullscreen
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e "s,gcc,${CC}," ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s,gcc,${CC}," \
+ -e "/${CC}/s,$$, -lX11," ${WRKSRC}/Makefile
do-install:
cd ${WRKSRC};\
- ${INSTALL_PROGRAM} ssh-askpass-fullscreen ${PREFIX}/bin/ssh-askpass-fullscreen;\
+ ${INSTALL_PROGRAM} ssh-askpass-fullscreen ${STAGEDIR}${PREFIX}/bin/ssh-askpass-fullscreen
.include <bsd.port.mk>