aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-07 20:42:58 +0800
committerkris <kris@FreeBSD.org>2004-03-07 20:42:58 +0800
commit71475b84ffa2c142e3720266aa0a5b1203640372 (patch)
tree6b16692656fb69fd1d1cbbc347511d950ce1c2de /security
parent3521c0d000b964ab9c5f39de5eec89b703bc24c4 (diff)
downloadfreebsd-ports-graphics-71475b84ffa2c142e3720266aa0a5b1203640372.tar.gz
freebsd-ports-graphics-71475b84ffa2c142e3720266aa0a5b1203640372.tar.zst
freebsd-ports-graphics-71475b84ffa2c142e3720266aa0a5b1203640372.zip
BROKEN on !i386 and !alpha: Does not compile
Diffstat (limited to 'security')
-rw-r--r--security/cryptopp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 0835d4cc6d2..8a2356bf521 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -47,6 +47,12 @@ HEADERFILES= 3way.h adler32.h aes.h algebra.h algparam.h arc4.h \
twofish.h validate.h wait.h wake.h winpipes.h words.h \
xormac.h xtr.h xtrcrypt.h zdeflate.h zinflate.h zlib.h
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Does not compile on !i386 and !alpha"
+.endif
+
pre-install:
${STRIP_CMD} ${WRKSRC}/cryptest
do-install:
@@ -62,4 +68,4 @@ do-install:
${CP} ${WRKSRC}/License.txt ${PREFIX}/share/doc/cryptopp/License
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>