aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /security
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-graphics-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-graphics-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-graphics-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'security')
-rw-r--r--security/gpass/Makefile3
-rw-r--r--security/gtkpasman/Makefile3
-rw-r--r--security/lasso/files/patch-lasso_errors.c11
-rw-r--r--security/pidgin-encryption/Makefile1
4 files changed, 18 insertions, 0 deletions
diff --git a/security/gpass/Makefile b/security/gpass/Makefile
index 9cb6068e208..f612814b00b 100644
--- a/security/gpass/Makefile
+++ b/security/gpass/Makefile
@@ -29,6 +29,9 @@ GCONF_SCHEMAS= gpass.schemas
post-patch:
@${REINPLACE_CMD} -e 's|{packageprefix}/share|{datadir}|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/include/gpass/error.h \
+ ${WRKSRC}/src/helper.h
post-install:
@-update-desktop-database
diff --git a/security/gtkpasman/Makefile b/security/gtkpasman/Makefile
index 7f11182ccea..adaf5ac5074 100644
--- a/security/gtkpasman/Makefile
+++ b/security/gtkpasman/Makefile
@@ -33,6 +33,9 @@ ACLOCAL_ARGS?= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
PORTDOCS= README gpasman4.sample
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Werror||g' ${WRKSRC}/src/Makefile.*
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/gtkpasman ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/data/gtkpasman.desktop \
diff --git a/security/lasso/files/patch-lasso_errors.c b/security/lasso/files/patch-lasso_errors.c
new file mode 100644
index 00000000000..adc329e68cb
--- /dev/null
+++ b/security/lasso/files/patch-lasso_errors.c
@@ -0,0 +1,11 @@
+--- lasso/errors.c.orig 2013-02-07 16:40:45.000000000 +0000
++++ lasso/errors.c 2013-02-07 16:40:54.000000000 +0000
+@@ -22,7 +22,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <lasso/errors.h>
+ #include <lasso/xml/xml.h>
+
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index 0754f8b6ec4..22c5a05d393 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -43,5 +43,6 @@ PLIST_SUB+= NLS="@comment "
post-extract:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|glib/.*\.h"|glib.h"|g' ${WRKSRC}/rsa_nss.c
.include <bsd.port.mk>