aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-16 19:57:30 +0800
committermiwi <miwi@FreeBSD.org>2007-03-16 19:57:30 +0800
commit84c50107da163865dce3e5c52852c1f342abac26 (patch)
tree192667680639c369a8d7be7d2300ecfaa6c7b1eb /security
parente0861f02d68e137d410fd45e20ea4c7a284ed490 (diff)
downloadfreebsd-ports-graphics-84c50107da163865dce3e5c52852c1f342abac26.tar.gz
freebsd-ports-graphics-84c50107da163865dce3e5c52852c1f342abac26.tar.zst
freebsd-ports-graphics-84c50107da163865dce3e5c52852c1f342abac26.zip
ocaml-ssl is a set of OCaml bindings for openssl.
WWW: http://savonet.sourceforge.net/wiki/OCamlLibs PR: ports/110303 Submitted by: Jaap Boender <jaapb at kerguelen.org>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/ocaml-ssl/Makefile52
-rw-r--r--security/ocaml-ssl/distinfo3
-rw-r--r--security/ocaml-ssl/pkg-descr3
-rw-r--r--security/ocaml-ssl/pkg-plist17
5 files changed, 76 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2d6d2bb48bc..849853ee959 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -287,6 +287,7 @@
SUBDIR += nss
SUBDIR += ocaml-cryptgps
SUBDIR += ocaml-cryptokit
+ SUBDIR += ocaml-ssl
SUBDIR += oidentd
SUBDIR += oinkmaster
SUBDIR += op
diff --git a/security/ocaml-ssl/Makefile b/security/ocaml-ssl/Makefile
new file mode 100644
index 00000000000..a42a3312302
--- /dev/null
+++ b/security/ocaml-ssl/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ocaml-ssl
+# Date created: March 14, 2007
+# Whom: Jaap Boender <jaapb@kerguelen.org>
+#
+# $FreeBSD$
+
+PORTNAME= ssl
+PORTVERSION= 0.4.1
+CATEGORIES= security devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= savonet
+PKGNAMEPREFIX= ocaml-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jaapb@kerguelen.org
+COMMENT= OpenSSL bindings for OCaml
+
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --docdir=${DOCSDIR}
+
+USE_OPENSSL= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAML_LDCONFIG= yes
+
+ALL_TARGET= all doc
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_MAN} ${WRKSRC}/doc/html/* ${DOCSDIR}/html
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/ocaml-ssl/distinfo b/security/ocaml-ssl/distinfo
new file mode 100644
index 00000000000..b7b941bb3d7
--- /dev/null
+++ b/security/ocaml-ssl/distinfo
@@ -0,0 +1,3 @@
+MD5 (ocaml-ssl-0.4.1.tar.gz) = 780c969a97e55c95d12b9a8e59688978
+SHA256 (ocaml-ssl-0.4.1.tar.gz) = bc1da3b6052ca92c2bc2d76b45ca33bb678246ca7453875d9a580f8e62d013f0
+SIZE (ocaml-ssl-0.4.1.tar.gz) = 109012
diff --git a/security/ocaml-ssl/pkg-descr b/security/ocaml-ssl/pkg-descr
new file mode 100644
index 00000000000..5d577254a5f
--- /dev/null
+++ b/security/ocaml-ssl/pkg-descr
@@ -0,0 +1,3 @@
+ocaml-ssl is a set of OCaml bindings for openssl.
+
+WWW: http://savonet.sourceforge.net/wiki/OCamlLibs
diff --git a/security/ocaml-ssl/pkg-plist b/security/ocaml-ssl/pkg-plist
new file mode 100644
index 00000000000..fff15d42565
--- /dev/null
+++ b/security/ocaml-ssl/pkg-plist
@@ -0,0 +1,17 @@
+%%OCAML_SITELIBDIR%%/ssl/dllssl_threads_stubs.so
+%%OCAML_SITELIBDIR%%/ssl/dllssl_stubs.so
+%%OCAML_SITELIBDIR%%/ssl/ssl_threads.a
+%%OCAML_SITELIBDIR%%/ssl/ssl.a
+%%OCAML_SITELIBDIR%%/ssl/libssl_threads_stubs.a
+%%OCAML_SITELIBDIR%%/ssl/libssl_stubs.a
+%%OCAML_SITELIBDIR%%/ssl/ssl_threads.cmxa
+%%OCAML_SITELIBDIR%%/ssl/ssl.cmxa
+%%OCAML_SITELIBDIR%%/ssl/ssl_threads.cma
+%%OCAML_SITELIBDIR%%/ssl/ssl.cma
+%%OCAML_SITELIBDIR%%/ssl/ssl_threads.cmi
+%%OCAML_SITELIBDIR%%/ssl/ssl.cmi
+%%OCAML_SITELIBDIR%%/ssl/ssl_threads.mli
+%%OCAML_SITELIBDIR%%/ssl/ssl.mli
+%%OCAML_SITELIBDIR%%/ssl/META
+@dirrmtry share/doc/ocaml/ssl/html
+@dirrmtry share/doc/ocaml/ssl