aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-04-16 02:50:02 +0800
committerdinoex <dinoex@FreeBSD.org>2003-04-16 02:50:02 +0800
commita755d8251d6d686523c9bcebaf597016e2870cb1 (patch)
tree7d755c71ec2515985ceee73fb0bb1750d4c7432c /security
parentf39a252599f565391587110069452be876201905 (diff)
downloadfreebsd-ports-graphics-a755d8251d6d686523c9bcebaf597016e2870cb1.tar.gz
freebsd-ports-graphics-a755d8251d6d686523c9bcebaf597016e2870cb1.tar.zst
freebsd-ports-graphics-a755d8251d6d686523c9bcebaf597016e2870cb1.zip
- honor any given LDFLAGS
Diffstat (limited to 'security')
-rw-r--r--security/hpn-ssh/Makefile1
-rw-r--r--security/openssh-portable/Makefile1
-rw-r--r--security/openssh/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index b46b3d91058..a6ad5333c7b 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -22,6 +22,7 @@ MAN8= sftp-server.8 sshd.8 ssh-keysign.8
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS=${LDFLAGS}
USE_PERL5_BUILD= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --with-md5-passwords
PRECIOUS= ssh_config sshd_config \
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index b46b3d91058..a6ad5333c7b 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -22,6 +22,7 @@ MAN8= sftp-server.8 sshd.8 ssh-keysign.8
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS=${LDFLAGS}
USE_PERL5_BUILD= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --with-md5-passwords
PRECIOUS= ssh_config sshd_config \
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 9a15035c715..b5ca34c40fa 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -46,6 +46,7 @@ PAM=no
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV+= DESTDIR=${PREFIX} MANDIR=/man/man CRYPTOLIBS="${CRYPTOLIBS}"
+MAKE_ENV+= LDFLAGS=${LDFLAGS}
.if ${OSVERSION} < 400014
MAKE_ENV+= COMPAT_GETADDRINFO=yes
ADDME+= netdb.h