aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 10:18:21 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 10:18:21 +0800
commitae62427d6d6725d1b89cb124a2b9df1780c3a6c0 (patch)
treef0efb79e0c88be76c10e56726918e912cd25d55e /security
parentf05d483448ee76fcaf403ea38e32d322986c8073 (diff)
downloadfreebsd-ports-graphics-ae62427d6d6725d1b89cb124a2b9df1780c3a6c0.tar.gz
freebsd-ports-graphics-ae62427d6d6725d1b89cb124a2b9df1780c3a6c0.tar.zst
freebsd-ports-graphics-ae62427d6d6725d1b89cb124a2b9df1780c3a6c0.zip
PERL -> REINPLACE
Noticed on: bento
Diffstat (limited to 'security')
-rw-r--r--security/bcwipe/Makefile3
-rw-r--r--security/chkrootkit/Makefile6
-rw-r--r--security/fwanalog/Makefile6
-rw-r--r--security/qident/Makefile4
4 files changed, 13 insertions, 6 deletions
diff --git a/security/bcwipe/Makefile b/security/bcwipe/Makefile
index 43237efc65a..e65b859ce86 100644
--- a/security/bcwipe/Makefile
+++ b/security/bcwipe/Makefile
@@ -14,12 +14,13 @@ DISTNAME= BCWipe-${PORTVERSION:S/./-/g:S/-/./}
MAINTAINER= crow@nektor.hu
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./-/g:S/-/./}
MAN1= bcwipe.1
post-patch:
- @${PERL} -pi -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bcwipe ${PREFIX}/bin
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index 81204762558..1081350d25a 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -12,6 +12,8 @@ MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/
MAINTAINER= cordeiro@luinil.nic.br
+USE_REINPLACE= yes
+
ALL_TARGET= chkrootkit chklastlog chkwtmp chkproc ifpromisc
DOCFILES= COPYRIGHT README README.chklastlog README.chkwtmp
@@ -19,8 +21,8 @@ DOCFILES= COPYRIGHT README README.chklastlog README.chkwtmp
BINMODE= 0700
pre-patch:
- ${PERL} -pi -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
- ${PERL} -pi -e \
+ ${REINPLACE_CMD} -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e \
's#\./chklastlog#${PREFIX}/sbin/chklastlog#g; \
s#\./chkwtmp#${PREFIX}/sbin/chkwtmp#g; \
s#\./chkproc#${PREFIX}/sbin/chkproc#g; \
diff --git a/security/fwanalog/Makefile b/security/fwanalog/Makefile
index cc4da4d9c53..9a8f334a6a5 100644
--- a/security/fwanalog/Makefile
+++ b/security/fwanalog/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= cy@FreeBSD.org
RUN_DEPENDS= analog:${PORTSDIR}/www/analog
+USE_REINPLACE= yes
ETCDIR= ${PREFIX}/etc/${PORTNAME}
PLIST_SUB+= ETCDIR=${ETCDIR}
CONFFILES= fwanalog-dom.tab \
@@ -24,10 +25,11 @@ CONFFILES= fwanalog-dom.tab \
services.conf
post-patch:
- ${PERL} -pi -e "s,the script's directory.*$$,${ETCDIR},;" \
+ ${REINPLACE_CMD} \
+ -e "s,the script's directory.*$$,${ETCDIR},;" \
-e 's,cd .*$$,cd ${ETCDIR},; s,sh\$$/,\$$/.,' \
${WRKSRC}/fwanalog.sh
- ${PERL} -pi -e 's/"freebsd/"ipf/; s/"ipflog/"messages/' \
+ ${REINPLACE_CMD} -e 's/"freebsd/"ipf/; s/"ipflog/"messages/' \
${WRKSRC}/fwanalog.opts.freebsd
do-build:
diff --git a/security/qident/Makefile b/security/qident/Makefile
index a5bc2995756..5d965958b07 100644
--- a/security/qident/Makefile
+++ b/security/qident/Makefile
@@ -14,6 +14,8 @@ MAINTAINER= dd@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libident.a:${PORTSDIR}/security/libident
+USE_REINPLACE= yes
+
MANSECTS= 1
MAN1= qident.1
MANCOMPRESSED= maybe
@@ -26,7 +28,7 @@ MANCOMPSUFFIX=
.endif
post-patch:
- @${PERL} -pi -e 's/getopt[.]h/unistd.h/g' ${WRKSRC}/*
+ @${REINPLACE_CMD} -e 's/getopt[.]h/unistd.h/g' ${WRKSRC}/*
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/qident ${PREFIX}/bin/qident