aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-05 21:19:44 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-05 21:19:44 +0800
commitb39ad26d67411638215e4dd64c9176d9791d0182 (patch)
tree9b27b5ea8ec32707d1786911099375136bef7294 /security
parent85dd1c97a2b2725c4f3d2dec3baf6682dcb86333 (diff)
downloadfreebsd-ports-graphics-b39ad26d67411638215e4dd64c9176d9791d0182.tar.gz
freebsd-ports-graphics-b39ad26d67411638215e4dd64c9176d9791d0182.tar.zst
freebsd-ports-graphics-b39ad26d67411638215e4dd64c9176d9791d0182.zip
- Regenerate python bytecode to fix references to stagedir
- Remove USES=desktop-file-utils as suggested by stage-qa - Add NO_ARCH Approved by: portmgr blanket
Diffstat (limited to 'security')
-rw-r--r--security/hotssh/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index c40b48e1a12..40113116960 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hotssh
PORTVERSION= 0.2.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security gnome
MASTER_SITES= GNOME
@@ -24,8 +24,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
USE_GNOME= pygtk2 gnomedocutils libxslt glib20 intltool
-USES= gettext python tar:bzip2 waf desktop-file-utils
+USES= gettext python tar:bzip2 waf
INSTALLS_ICONS= yes
+NO_ARCH= yes
B64DECODE?= /usr/bin/b64decode
BSPATCH?= /usr/bin/bspatch
@@ -36,4 +37,8 @@ post-extract:
@cd ${WRKSRC} && ${B64DECODE} -o waf.diff ${FILESDIR}/waf.diff && ${BSPATCH} waf.beforepatch waf waf.diff && ${CHMOD} 755 waf
@${GREP} -Rl '%%LOCALBASE%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g"
+post-install:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
.include <bsd.port.mk>