aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2002-04-02 20:58:21 +0800
committermarkp <markp@FreeBSD.org>2002-04-02 20:58:21 +0800
commitb734b68b41b95160a002c55ebddf0edb28e0be69 (patch)
treec7a55c49bfc74c495e9460fa277791c06d7901dc /security
parentcc178b19799346b514240577dec0451cd57930f1 (diff)
downloadfreebsd-ports-graphics-b734b68b41b95160a002c55ebddf0edb28e0be69.tar.gz
freebsd-ports-graphics-b734b68b41b95160a002c55ebddf0edb28e0be69.tar.zst
freebsd-ports-graphics-b734b68b41b95160a002c55ebddf0edb28e0be69.zip
Add vlog 1.1f, a curses based real-time logfile viewer.
PR: 36616 Submitted by: hannes sowa <satbran@web.de>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/vlog/Makefile28
-rw-r--r--security/vlog/distinfo1
-rw-r--r--security/vlog/pkg-comment1
-rw-r--r--security/vlog/pkg-descr21
-rw-r--r--security/vlog/pkg-plist1
6 files changed, 53 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 744905f61f0..527c18a9498 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -252,6 +252,7 @@
# SUBDIR += tripwire12
SUBDIR += uvscan-dat
SUBDIR += vlock
+ SUBDIR += vlog
SUBDIR += vpnd
SUBDIR += vscan
SUBDIR += whisker
diff --git a/security/vlog/Makefile b/security/vlog/Makefile
new file mode 100644
index 00000000000..13086ee7bc5
--- /dev/null
+++ b/security/vlog/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: vlog
+# Date created: 31 March 2002
+# Whom: hannes sowa <satbran@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vlog
+PORTVERSION= 1.1f
+CATEGORIES= security
+MASTER_SITES= http://inc2.com/download/
+DISTNAME= vlog-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= satbran@web.de
+
+ALL_TARGET= it
+MAKE_ARGS= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${PTHREAD_LIBS} -lcurses"
+WRKSRC= ${WRKDIR}/vlog
+
+MAN1= vlog.1
+MANCOMPRESSED= no
+
+post-patch:
+ ${PERL} -pi -e "s@/usr/local@${PREFIX}@g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/vlog/distinfo b/security/vlog/distinfo
new file mode 100644
index 00000000000..1c309af974b
--- /dev/null
+++ b/security/vlog/distinfo
@@ -0,0 +1 @@
+MD5 (vlog-1.1f.tgz) = d60b2d615b9e94cc380859bf72845fb4
diff --git a/security/vlog/pkg-comment b/security/vlog/pkg-comment
new file mode 100644
index 00000000000..0343fda10aa
--- /dev/null
+++ b/security/vlog/pkg-comment
@@ -0,0 +1 @@
+A curses based real-time logfile viewer
diff --git a/security/vlog/pkg-descr b/security/vlog/pkg-descr
new file mode 100644
index 00000000000..5e6a4b7799d
--- /dev/null
+++ b/security/vlog/pkg-descr
@@ -0,0 +1,21 @@
+vlog is a curses based real-time logfile viewer. It was designed
+to meet the following needs:
+
+ipmon viewer display IP-Filter log lines in a scrollable window
+ in a readable way
+
+real time viewing window receives log lines as soon as they're
+ appended to the log file
+
+old logfiles vlog can show the old rotated log files
+
+selecting log log lines to be viewed can be selected with a regexp
+lines given on the command line
+
+customizing one can control which fields are displayed
+display
+
+WWW: http://inc2.com/isba/index-vlog.html
+
+- Hannes Sowa
+satbran@web.de
diff --git a/security/vlog/pkg-plist b/security/vlog/pkg-plist
new file mode 100644
index 00000000000..a83ed21389d
--- /dev/null
+++ b/security/vlog/pkg-plist
@@ -0,0 +1 @@
+bin/vlog