aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-22 17:19:54 +0800
committererwin <erwin@FreeBSD.org>2005-12-22 17:19:54 +0800
commitc4c6853bad11995bcfc4144be639e7903d80c414 (patch)
tree0d2fa9840aca086092e0f3af87e0600851bb88db /security
parent4801d30a3b9640ce5027bfdd93c83e32e56e7ea1 (diff)
downloadfreebsd-ports-graphics-c4c6853bad11995bcfc4144be639e7903d80c414.tar.gz
freebsd-ports-graphics-c4c6853bad11995bcfc4144be639e7903d80c414.tar.zst
freebsd-ports-graphics-c4c6853bad11995bcfc4144be639e7903d80c414.zip
Digest::Pearson::PurePerl is an implementation of Peter K. Pearson's hash
algorithm presented in "Fast Hashing of Variable Length Text Strings" - ACM 1990. This hashing technique yields good distribution of hashed results for variable length input strings on the range 0-255, and thus, it is well suited for data load balancing. If you prefer a fast implementation, you might want to consider Digest::Pearson instead. WWW: http://search.cpan.org/dist/Digest-Pearson-PurePerl PR: ports/90770 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-Pearson-PurePerl/Makefile24
-rw-r--r--security/p5-Digest-Pearson-PurePerl/distinfo3
-rw-r--r--security/p5-Digest-Pearson-PurePerl/pkg-descr9
-rw-r--r--security/p5-Digest-Pearson-PurePerl/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8807e7f287c..84650ed502e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -376,6 +376,7 @@
SUBDIR += p5-Digest-ManberHash
SUBDIR += p5-Digest-Nilsimsa
SUBDIR += p5-Digest-Pearson
+ SUBDIR += p5-Digest-Pearson-PurePerl
SUBDIR += p5-Digest-SHA
SUBDIR += p5-Digest-SHA1
SUBDIR += p5-Digest-SHA2
diff --git a/security/p5-Digest-Pearson-PurePerl/Makefile b/security/p5-Digest-Pearson-PurePerl/Makefile
new file mode 100644
index 00000000000..f6776021772
--- /dev/null
+++ b/security/p5-Digest-Pearson-PurePerl/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-Pearson-PurePerl
+# Date created: 21 Dec, 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-Pearson-PurePerl
+PORTVERSION= 1.00
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Peter K. Pearson's hash algorithm in pure Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Pearson::PurePerl.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-Pearson-PurePerl/distinfo b/security/p5-Digest-Pearson-PurePerl/distinfo
new file mode 100644
index 00000000000..65b78a5f8a7
--- /dev/null
+++ b/security/p5-Digest-Pearson-PurePerl/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-Pearson-PurePerl-1.00.tar.gz) = 0f734a4533b692bac2608266b4fb3b55
+SHA256 (Digest-Pearson-PurePerl-1.00.tar.gz) = b2fcee48ce7c277f1941a01ac95f41fa43267e93057700d37b4a233fe27f632a
+SIZE (Digest-Pearson-PurePerl-1.00.tar.gz) = 2614
diff --git a/security/p5-Digest-Pearson-PurePerl/pkg-descr b/security/p5-Digest-Pearson-PurePerl/pkg-descr
new file mode 100644
index 00000000000..009d397bc25
--- /dev/null
+++ b/security/p5-Digest-Pearson-PurePerl/pkg-descr
@@ -0,0 +1,9 @@
+Digest::Pearson::PurePerl is an implementation of Peter K. Pearson's hash
+algorithm presented in "Fast Hashing of Variable Length Text Strings"
+- ACM 1990. This hashing technique yields good distribution of hashed results
+for variable length input strings on the range 0-255, and thus, it is well
+suited for data load balancing.
+If you prefer a fast implementation, you might want to
+consider Digest::Pearson instead.
+
+WWW: http://search.cpan.org/dist/Digest-Pearson-PurePerl
diff --git a/security/p5-Digest-Pearson-PurePerl/pkg-plist b/security/p5-Digest-Pearson-PurePerl/pkg-plist
new file mode 100644
index 00000000000..9e482faf0dc
--- /dev/null
+++ b/security/p5-Digest-Pearson-PurePerl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Digest/Pearson/PurePerl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Pearson/PurePerl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Pearson/PurePerl/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Pearson/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Digest/Pearson/
+@unexec rmdir %D/%%SITE_PERL%%/Digest/ 2>/dev/null || true