aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-10-11 07:11:03 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-10-11 07:11:03 +0800
commitc6aa5d193c399b801602c23e0c06f5690b59124d (patch)
tree9de58928b7128a797a3035d203f97f3f3f8ed93e /security
parentbd2808f1a07cd9d2db37a3924142798a496c4f21 (diff)
downloadfreebsd-ports-graphics-c6aa5d193c399b801602c23e0c06f5690b59124d.tar.gz
freebsd-ports-graphics-c6aa5d193c399b801602c23e0c06f5690b59124d.tar.zst
freebsd-ports-graphics-c6aa5d193c399b801602c23e0c06f5690b59124d.zip
- Add rubygem-sshkey 1.7.0
SSHKey generates private and public SSH keys (RSA and DSA supported) using pure Ruby. WWW: https://github.com/bensie/sshkey
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-sshkey/Makefile20
-rw-r--r--security/rubygem-sshkey/distinfo2
-rw-r--r--security/rubygem-sshkey/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 298eda1ca5d..80125c9c112 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -960,6 +960,7 @@
SUBDIR += rubygem-ruby-saml
SUBDIR += rubygem-scrypt
SUBDIR += rubygem-six
+ SUBDIR += rubygem-sshkey
SUBDIR += rubygem-sshkit
SUBDIR += rubygem-twitter_oauth
SUBDIR += safesh
diff --git a/security/rubygem-sshkey/Makefile b/security/rubygem-sshkey/Makefile
new file mode 100644
index 00000000000..7949cccbd2d
--- /dev/null
+++ b/security/rubygem-sshkey/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sshkey
+PORTVERSION= 1.7.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Generate private/public SSH keypairs using pure Ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-sshkey/distinfo b/security/rubygem-sshkey/distinfo
new file mode 100644
index 00000000000..6cfc76252a8
--- /dev/null
+++ b/security/rubygem-sshkey/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/sshkey-1.7.0.gem) = bbe4950847a0507ef277e706cead1bf8f2634650356df86bcced22b928513195
+SIZE (rubygem/sshkey-1.7.0.gem) = 24064
diff --git a/security/rubygem-sshkey/pkg-descr b/security/rubygem-sshkey/pkg-descr
new file mode 100644
index 00000000000..0eea2e0cbad
--- /dev/null
+++ b/security/rubygem-sshkey/pkg-descr
@@ -0,0 +1,4 @@
+SSHKey generates private and public SSH keys (RSA and DSA supported) using pure
+Ruby.
+
+WWW: https://github.com/bensie/sshkey