aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-05 07:56:42 +0800
committeredwin <edwin@FreeBSD.org>2003-02-05 07:56:42 +0800
commitd39cdf1392e666eee66e94b943b6aedc6dd25997 (patch)
treed6fc9f34f5347c824c390a00089aa7be1f11d9c9 /security
parent1cbeab1f00e0950dda586a0fe6a69011621646ff (diff)
downloadfreebsd-ports-graphics-d39cdf1392e666eee66e94b943b6aedc6dd25997.tar.gz
freebsd-ports-graphics-d39cdf1392e666eee66e94b943b6aedc6dd25997.tar.zst
freebsd-ports-graphics-d39cdf1392e666eee66e94b943b6aedc6dd25997.zip
New Port: security/p5-Crypt-Blowfish_PP
Blowfish is a published algorithm written by Bruce Schneier Unlike IDEA or DES etc. there are no patent implications in using this algorithm. It uses anywhere between a 64 bit and a 448 bit key. The transform itself is fast and operates on a 64 bit block, and most of the calculation time is in initialising the context with the key data. The _PP name comes from the fact that this implementation is Pure Perl, and will not have any compatibility problems. PR: ports/43794 Submitted by: Jim Geovedi <negative@toxic.magnesium.net>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Blowfish_PP/Makefile22
-rw-r--r--security/p5-Crypt-Blowfish_PP/distinfo1
-rw-r--r--security/p5-Crypt-Blowfish_PP/pkg-comment1
-rw-r--r--security/p5-Crypt-Blowfish_PP/pkg-descr10
-rw-r--r--security/p5-Crypt-Blowfish_PP/pkg-plist6
6 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index aa3b84a7ff5..f8e8f85ff97 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -164,6 +164,7 @@
SUBDIR += p5-Authen-TacacsPlus
SUBDIR += p5-Authen-Ticket
SUBDIR += p5-Crypt-Blowfish
+ SUBDIR += p5-Crypt-Blowfish_PP
SUBDIR += p5-Crypt-CAST5_PP
SUBDIR += p5-Crypt-CBC
SUBDIR += p5-Crypt-CipherSaber
diff --git a/security/p5-Crypt-Blowfish_PP/Makefile b/security/p5-Crypt-Blowfish_PP/Makefile
new file mode 100644
index 00000000000..d00547af239
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Crypt-Blowfish_PP
+# Date created: Sep 30, 2002
+# Whom: Jim Geovedi <jim@corebsd.or.id>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Blowfish_PP
+PORTVERSION= 1.12
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jim@corebsd.or.id
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Blowfish_PP.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Blowfish_PP/distinfo b/security/p5-Crypt-Blowfish_PP/distinfo
new file mode 100644
index 00000000000..24f55869717
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-Blowfish_PP-1.12.tar.gz) = 6bf7dc80967eaf3047b67b26b015267d
diff --git a/security/p5-Crypt-Blowfish_PP/pkg-comment b/security/p5-Crypt-Blowfish_PP/pkg-comment
new file mode 100644
index 00000000000..a8c58aad927
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/pkg-comment
@@ -0,0 +1 @@
+Blowfish encryption algorithm implemented purely in Perl
diff --git a/security/p5-Crypt-Blowfish_PP/pkg-descr b/security/p5-Crypt-Blowfish_PP/pkg-descr
new file mode 100644
index 00000000000..7ffaf54a527
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/pkg-descr
@@ -0,0 +1,10 @@
+Blowfish is a published algorithm written by Bruce Schneier Unlike
+IDEA or DES etc. there are no patent implications in using this
+algorithm.
+
+It uses anywhere between a 64 bit and a 448 bit key. The transform
+itself is fast and operates on a 64 bit block, and most of the
+calculation time is in initialising the context with the key data.
+
+The _PP name comes from the fact that this implementation is Pure
+Perl, and will not have any compatibility problems.
diff --git a/security/p5-Crypt-Blowfish_PP/pkg-plist b/security/p5-Crypt-Blowfish_PP/pkg-plist
new file mode 100644
index 00000000000..95c0078786a
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Blowfish_PP.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Blowfish_PP/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Blowfish_PP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Crypt 2>/dev/null || true